Green Tractor Talk banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I just started having a problem that when running the mid mount mower that the engine will bog way down. If I cut the PTO the engine recovers to normal RPM. The weird part is that it will mow for about 20 sec - 1 min, then bog. I tried it with the mower up and there is no change. The first time it happened it only lasted a few minutes, then I was able to mow the rest of the lawn (2+hrs) with no issues. Today the problem seemed more severe, so I parked the tractor and thought I would look for causes.

Here are the three things I was going to do:
New Fuel Filter (About Due)
Change Hydrostatic Fluid and Filter
Check individual spindals on mower to see if a bearing is going bad

Any other ideas?
 

·
Registered
Joined
·
280 Posts
also, check to see if the underneth of the mower deck is clogged up (can cause a major hp drop) also check for twine in the spindles and put about 1 or 2 pumps of grease in the spindle .


good luck



EDIT:

also your diesel might be contaminated. did you just fill it up? also when you change your fuel filter check to see if the filter is extra dirty
 

·
Administrator
Joined
·
18,471 Posts
I think you both listed the things to check first.

One other item might be the vent in the fuel cap, but I doubt that is it...
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
It was the fuel filter

What a nasty mess. My Dad has been helping me out and was able to change the fuel filter today and it was nasty. A line flush, new fuel and a filter fixed everything. Now I can get to the hydrostatic after leaf season.
 

·
Premium Member
Joined
·
6,593 Posts
Glad to hear you are back in business. :good2:
 
1 - 5 of 5 Posts
Top