Green Tractor Talk banner

1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1 (Edited)
Hello,

My Headlights/Tail lights keep blowing the 25amp fuse on my JD 2320. I have used a test light to trouble shoot and it looks like the Wire that is causing the short is a Red wire with a Yellow strip. What I am not able to find is a wiring diagram for the tractor so I can trouble shoot more.

The reason I believe it is this wire is from the plug at the light switch. If I leave one test light where the 25amp fuse is and another test light between the White/Blue wire and the Red/Yellow wire the test lights light up. All other wire combination do not light up. (note when doing this I have remove the 10 amp fuses from the fuse box, I believe these are fuse for the turn signals, I have also removed all light bulbs in the tail lights, and unplugs the head lights)

I have search google for a wiring diagram but have not been able to locate one.
Does anyone know what this Red/Yellow wire feeds? Tail lighs, Headlights,? Another light
Is there another light I am missing on the Tractor?

Any help with would be great

Thanks

Kevin
 

·
Administrator
Joined
·
18,291 Posts
Welcome to GTT Kevin,
You will have to purchase the Technical Manual to get the wiring diagrams. Someone may be able to help by posting a page or two but you will be well served to purchase the CD if you intend to do your own wrenching. At less than $70 they are well worth it:

Green Farm Parts: John Deere Parts Online at Discount Prices
 

·
Premium Member
Joined
·
7,816 Posts
Hello,

My Headlights/Tail lights keep blowing the 25amp fuse on my JD 2320. I have used a test light to trouble shoot and it looks like the Wire that is causing the short is a Red wire with a Yellow strip. What I am not able to find is a wiring diagram for the tractor so I can trouble shoot more.

The reason I believe it is this wire is from the plug at the light switch. If I leave one test light where the 25amp fuse is and another test light between the White/Blue wire and the Red/Yellow wire the test lights light up. All other wire combination do not light up. (note when doing this I have remove the 10 amp fuses from the fuse box, I believe these are fuse for the turn signals, I have also removed all light bulbs in the tail lights, and unplugs the head lights)

I have search google for a wiring diagram but have not been able to locate one.
Does anyone know what this Red/Yellow wire feeds? Tail lighs, Headlights,? Another light
Is there another light I am missing on the Tractor?

Any help with would be great

Thanks

Kevin
If I understand correctly;

1) 25A fuse for head/tail lights blows
2) You put a test light across where the 25A should be. (Good idea, with a short, the light will be "ON" rather than a fuse blowing.
3) With a second light across WH/BLU to RD/YEL wires at light switch, that light comes "ON"
4) You removed the following loads, Headlights, all taillight bulbs.

My first guess is RD/YEL wire "might" go the dash? Dash lights?

To find where the RD/YEL goes, I would check the connectors. I doubt the wire changed color connector to connector. I would start at the dash.

I think I would remove the RD/YEL wire from the light switch connector and put all the "loads" back in, headlights, rear bulbs and check for operation. If something does not work, you know the RD/YEL wire is involved.

Sorry I can't be of more help.

.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Zebrafive,

I thought the same thing. That the dash light or lights might be the issue. So I unplugged the Dash while doing this test, so if the dash was the issue the short would have been removed. So that is how I narrowed it down to the red/Yel wire. The wire leaves the white Terminal Plug from the back of the light switch down behind the gas tank. It is part of all the wires leaving the switch in a black plastic pipping.

At this point i was able to find the Wires going to the head lights look to be a Red/White wire. So I am guessing it has to do with the tail lights

I was able to get the hazard lights in the rear to work, once i put the 10 amp fuse in. Which would cancel out part of the tail lights. As there are two bulbs in each tail light

So far I have wiggled what i believe are the wires that run from the switch back to the Tail lights but have not been able to find the short or get the Test light to flutter when i am wiggling the wires.

I am wondering is there is another load (Bulb, Relay, etc) that is controlled by the light switch or the red/yel wire.
 

·
Registered
Joined
·
255 Posts
Have you checked the wiring from the lights going into the ROPS? sometimes wires will get pinched where the lights screw into the side. This happened a few times when we are adding a back hoe, you have to raise the lights with extensions and sometimes you will pinch a wire when putting a bolt through.
 

·
Registered
Joined
·
474 Posts
Check the wire that is giving you issues to ground. If it is blowing a fuse you either have a short or too much on that wire.

You can also disconnect that wire and see what if anything lights up. If it is your supply line you will have no lights at all. If it is a grounded lead and you disconnect it you will have everything on EXCEPT the light(s) that are on that lead. Once you know which light(s) are on it you can more easily trace the wires since you know where they run to.

Good luck, chasing wires can be time consuming. Isolating the start and end points will speed the process along.
 
1 - 6 of 6 Posts
Top