Green Tractor Talk banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Can any tell me what might be the problem with my 2955 hydraulics? After using for awhile idle down and hyd. light started to flicker, so i changed the filter and hyd oil. Same thing and sometimes the loader will get jerky. Not sure where to start. thanks
 

·
Registered
Joined
·
896 Posts
There are many possibilities. Did you check and clean the sump screen when you changed the oil? If not I would start there. If there is debris in the screen, you need to try and identify what it is. Could be clogged with brake material, clutch material from pto or hi-lo, or could just be contamination from dirt, etc. If screen is not clogged, then you most likely have a leak inside the transmission at the pto, pto brake, hi-lo clutch, broken oil line, or just a worn transmission pump. That light you see blinking at idle blinks when transmission pressure is low. When the transmission pressure is low, the main hydraulic pump starves for oil. To try and isolate the problem, try running with pto on for a while and see if things improve. If not turn pto off and see if that helps. Then try running hi-lo in low for a while and then run in low for a while. If hydraulics get better in any of those operating conditions, you can determine where the leak is occurring. If nothing makes improvement, then most likely the pump is worn or an internal oil line could be cracked. Unfortunately most of these problems require splitting the tractor between clutch housing and transmission housing to repair.
 

·
Registered
Joined
·
1,775 Posts
I think jd110 covered hyd diagnostics very well. I'll add with engine running,3 pt raised look in hyd filler hole for moving oil which would indicate leaking rockshaft control valve seals or piston seal. What type valve controls loader(scv or ind)?
 
1 - 3 of 3 Posts
Top