Green Tractor Talk banner

1 - 2 of 2 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Have a few issues with a John Deere 300 D backhoe. Bought it used at about 4000 hours, it now has about 4100. The issues I have are the oil filter light and battery light come on when I first crank up and the tachometer will not work. When it warms up for a few minutes and I increase RPM’s all lights will go off and hour meter works. no working lights or turn signals will work. I checked for voltage at switch and it has like 6 volts on one terminal. No voltage going to the light, however. same goes for the horn. Also, I repacked stabilizer cylinders and dipper cylinder using kits from Hydraulics works website. The cylinders work fine but the very most outer seal is different from the stock ones and tends to come out over time and will leak. I just tap it back in and it’ll stay dry, but it’s just annoying. Recommendations for a good after market rebuild kit? Any suggestions on where to start for electrical issues? Other than that the backhoe cranks up and runs great. has faint white smoke and occasional puffs of black smoke at idle but when revved up its clear. Thanks.

Jeremy
 

·
Chief Stick-picker-upper
Joined
·
11,754 Posts
Have a few issues with a John Deere 300 D backhoe. Bought it used at about 4000 hours, it now has about 4100. The issues I have are the oil filter light and battery light come on when I first crank up and the tachometer will not work. When it warms up for a few minutes and I increase RPM’s all lights will go off and hour meter works. no working lights or turn signals will work. I checked for voltage at switch and it has like 6 volts on one terminal. No voltage going to the light, however. same goes for the horn.
Check the grounding locations. You should have 12 volts at all connection.

Also, I repacked stabilizer cylinders and dipper cylinder using kits from Hydraulics works website. The cylinders work fine but the very most outer seal is different from the stock ones and tends to come out over time and will leak. I just tap it back in and it’ll stay dry, but it’s just annoying. Recommendations for a good after market rebuild kit? Any suggestions on where to start for electrical issues? Other than that the backhoe cranks up and runs great. has faint white smoke and occasional puffs of black smoke at idle but when revved up its clear. Thanks.

Jeremy
Check with a local hydraulics shop. They should have whatever you need.
 
1 - 2 of 2 Posts
Top