Green Tractor Talk banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Last season I inherited an ‘89 JD 420. The previous owner had upgraded the engine to a 23hp Briggs and Stratton Vanguard. Tractor worked well for me all season then after one mow the PTO (mower) wouldn’t shut off. Parked it in the driveway and it wouldn’t restart, getting the classic solenoid click. Tried to troubleshoot by replacing battery, PTO switch and starter solenoid with no luck. Then I tried the starter assist relay and still nothing. I would get a click and sometimes a high pitched squeal from the starter or solenoid and the solenoid pole that goes to the motor would smoke. Then it sat outside all winter bc i’m an idiot.

Got it into my garage this spring and went through the electrical checkout as best I could and replaced the starter motor and ignition switch and the cable going from solenoid to starter and removed the assist relay. Grounds all clean and solid. Connections clean and solid. 12.8V at the battery and solenoid. When i tried to bypass the solenoid I get a MAJOR spark that I can’t bring myself to hold the screwdriver through. The spark scorches and dents the screwdriver so it seems too big, plus i hear no action from the starter motor..

Park brake always set. Pretty sure all Safety switches are good (PTO and ignition switches are new and the brake and neutral switches had power on testing). Seat switch maybe? I taped the button down for this testing. In the past i cut the 2 wires going to the seat switch and connected them to bypass it but then undid it and may have done a poor job, could that be it?

So today with new solenoid the starter or solenoid clicked sometimes, sometimes squeals like before and one time i heard the starter motor clunk a couple times before making some sparking/zapping noise and smoking (from the new starter motor itself). Now i get nothing.

wondering if i had the right new starter and solenoid? I matched the new starter motor to the briggs and stratton engine i have and it looks just like the one i pulled, and replaced the solenoid with the exact one I pulled.

Another new battery or a 3rd solenoid? The new battery i got was budget and only 575 CCA but it’s been showing 12.8V since i drip charged it.

What should i do next!? I dont have a trailer to take it in. need this thing runnin! grass is gettin looong!!!
 

·
Registered
Joined
·
514 Posts
A common problem with these tractors can sometimes be traced back to a failed ignition switch. Swap out the switch, clean the connectors well, and reassemble
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
already replaced the switch. How do you recommend i clean the wire end connections female connections?
 
1 - 3 of 3 Posts
Top