Green Tractor Talk banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 4300 LCUT (2000 model) that the Fuel and temperature Gauges have stopped working.

Does anyone have any information about who can repair these Instrument Clusters?
 

·
Registered
Joined
·
253 Posts
I have a 4300 LCUT (2000 model) that the Fuel and temperature Gauges have stopped working.

Does anyone have any information about who can repair these Instrument Clusters?
Can you describe what you mean by "stopped working?" I have the diagnostics for this tractor and it may point to something else. I thought my fuel gauge was faulty - turned out to be the sensor. Saved some money.

If you're interested in "borrowing" my manual, let me know.
 

·
Registered
Joined
·
253 Posts
I did some checking last night on the wiring diagram. Both of these gauges seem to be fed through the same connector on the back. I would offer it might be helpful to check the wires. There's a 10 pin and a 6 pin connectors on the back of the PC board. I think the wires you are interested in are on the 10-pin connector.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
I did some checking last night on the wiring diagram. Both of these gauges seem to be fed through the same connector on the back. I would offer it might be helpful to check the wires. There's a 10 pin and a 6 pin connectors on the back of the PC board. I think the wires you are interested in are on the 10-pin connector.
Thanks for the info. The Temperature gauge needle is over by the High Temp area when the tractor is shut off and then goes off the gauge past Hot when the tractor starts. The Fuel Gauge is in the middle of the Gauge when the tractor is shut off and goes off the gauge when the tractor starts.

I have checked the connections but the needles stay in the same spots when I unplug the connector from the back of the cluster.

When I stopped at my local JD Dealer Service Department, they said this is a common problem and they recommended that I replace the Gauge Cluster or find someone to repair it. They recommended that I check the Fuel Sensor by grounding it. Based on the info that I found in the forums on this site (resistance measurements) the sensors are working correctly.

Does anyone know of a repair service that can repair my Instrument Cluster?
 

·
Registered
Joined
·
253 Posts
Thanks for the info. The Temperature gauge needle is over by the High Temp area when the tractor is shut off and then goes off the gauge past Hot when the tractor starts. The Fuel Gauge is in the middle of the Gauge when the tractor is shut off and goes off the gauge when the tractor starts.

I have checked the connections but the needles stay in the same spots when I unplug the connector from the back of the cluster.

When I stopped at my local JD Dealer Service Department, they said this is a common problem and they recommended that I replace the Gauge Cluster or find someone to repair it. They recommended that I check the Fuel Sensor by grounding it. Based on the info that I found in the forums on this site (resistance measurements) the sensors are working correctly.

Does anyone know of a repair service that can repair my Instrument Cluster?
I sent you a PM with a link to a factory service manual. Maybe that will help. I re-read the section in the manual and the diagnostics and recommend following them before proceeding. They are on page 4-58.

When my fuel sensor shorted out, it allowed significant voltage to be fed to the gauge. It cause the needle to move on the shaft. After repairing the sensor, I had to reposition the needle to get the correct reading.

Hopefully the manual will save you some money. I'm sorry but I don't know how to repair the gauges if they are damaged. JD says "replace the instrument cluster" - that's pricey.

J
 
1 - 5 of 5 Posts
Top