Green Tractor Talk banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a brand new 44 inch blower on my 300 X. When I engage it the pulley hits into the housing before returning back to where it is supposed to be. Dealer looked at it and said the shear pins were too tight. They brought it back and it seemed better. I went out today to run the tractor and engaged the blower. It is hitting once again. It seems better when the blower is raised and worse when all the way down. Any suggestions or is this normal upon engagement?
 

·
Registered
Joined
·
3,554 Posts
I don't have an answer, just a suggestion. If you don't get any action in this part of the forum post your thread in the Lawn and Garden Tractor section. More guys with 300's will see it there.:thumbup1gif:
 

·
Super Moderator
Joined
·
5,293 Posts

·
Registered
Joined
·
88 Posts
I have a brand new 44 inch blower on my 300 X. When I engage it the pulley hits into the housing before returning back to where it is supposed to be. Dealer looked at it and said the shear pins were too tight. They brought it back and it seemed better. I went out today to run the tractor and engaged the blower. It is hitting once again. It seems better when the blower is raised and worse when all the way down. Any suggestions or is this normal upon engagement?
I had a 44" blower on my X500 for a long time and it never did anything like that. I went through a few of the idler pulleys because the bearings rust out from water sitting in them but nothing ever with the main pulley.
 
1 - 4 of 4 Posts
Top