Green Tractor Talk banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
our 4430 was pulling a sprayer when hyd functions became slow steering slowed and tractor acted like clutch was slipping we changed filters tryd the destroke valve and made sure screen was clean none of that has done anything it had a power beyound on it but we took it off cause it was suggested that could have contributed to the problem now dont know witch direction to go any suggestions:banghead:
 

·
Registered
Joined
·
1,129 Posts
Since the problem includes clutch slippage, I suspect no problem with main hydraulic pump or high pressure circuit problems. Problem more likely in a worn transmission pump, leak in a transmission clutch or circuit, stuck filter relief valve, etc. type of transmission depends on where these components are and how to test for the problem.
 

·
Premium Member
Joined
·
3,456 Posts
Ditto what jd110 stated clutch problem is is in low pressure circuit. One of the easier things to check is condition of trans pump driveshaft(parts key 25). I presume your tractor has a QR trans. Remove 3pt centerlink attaching bracket then remove plug. Start engine then look to determine if shaft is spinning at engine idle speed. Stop engine then pull shaft out checking for wear at trans pump location on shaft.
 

Attachments

1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top