Green Tractor Talk banner

1 - 15 of 15 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter · #1 ·
I am in the process of getting a hydraulic filter and changing the fluid. I know there is around 9 gallons of fluid according to my JD dealer. My question is how many drain plugs and where are they located to allow me to drain the system and change the filter and clean the screen? I want to get it drained tonight as my new seal for the plate on the transmission will be here Friday morning (my leak is from the plate on the bottom)

I got this tractor less then 6 months ago and have been fixing all kinds of neglected stuff. I had never checked the hydraulic fluid and I am kicking myself in the butt. I pulled the loader cylinders and had them gone through and repaired by a hydraulic shop and that took care of the loader falling down when lifted up, previous owner had them put together wrong.
Anyway I never checked the fluid level and with it leaking underneath and removal of all 4 loader cylinders plus installation the rear dip stick shows nothing on it. I fianly checked it when I hear the pump chattering at idle and when moving at low speeds. High RPM and driving at more then an idle the noise goes away. I hope with the unit being low I didn't screw it up. Tractor drives, power steering works and loader works fine just a chatter at low idle sitting there. Do you think it is now junk?
 

·
Registered
Joined
·
1,235 Posts
Do you have an Operator's Manual? If not you can download one from here JD Tech Info Store .

Don't forget to clean the suction screen. I bought a new gasket and hose for my original 4200.
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #3 ·
thank you I do plan on cleaning the screen. the tractor was 1-1/4 to 1-1/2 gallons low to hit the dip stick, took 2 full gallons to be on the dip stick where it needs to be. good news is the tractor doesn't make anymore noise. hope that was the problem. This weekend I will change all the hydraulic fluid filter and screen. I hated to add 2 gallons of fluid but wanted piece of mind that it was going to be ok.
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #4 ·
Do you have an Operator's Manual? If not you can download one from here JD Tech Info Store .

Don't forget to clean the suction screen. I bought a new gasket and hose for my original 4200.
I have the technical manual but not an operators manual and the technical manual didn't have anything on how to change the fluid. going to get the operators manual now. Thanks again
 

·
Premium Member
Joined
·
15,180 Posts
I have the technical manual but not an operators manual and the technical manual didn't have anything on how to change the fluid. going to get the operators manual now. Thanks again
Oddly, JD has a habit of not including information in the Technical Manual that is listed in the Operator's Manual and visa versa.
 
  • Like
Reactions: farmer52

·
Registered
Joined
·
2,036 Posts
yours is hystat? not power reverser?

per my manual (opperators) ....your right its not in the tech manual

one oil drain plug under transmission

also a drain plug at screen cap ...last time i did my hydraulic service i couldnt remove the drainplug on the screen cap so i just removed the whole cap`(two bolts) which you need to do anyways to clean the screen

per book hystat holds 8.8-9.25gal (depending on where you look in book)......of J20D ( lowvis )
782000
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #7 ·
I am guessing the optional mid-mount PTO gearbox is used to drive the FWD unit so that will need to get drained as well?
 

·
Registered
Joined
·
2,036 Posts
I am guessing the optional mid-mount PTO gearbox is used to drive the FWD unit so that will need to get drained as well?
No ...I highly doubt you have mid pto ...it would run a belly mower or something like that.....mid pto is not fwd....but if you actually have a mid pto then yes per manual above it would need drained...
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #10 ·
ok thanks, I know there is not one I just thought the shaft that drove the front wheel assist was possibly what they were talking about
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #11 ·
I found 3 drain plugs one in the main transmission, one on the filter screen housing and one up father where the front drive shaft connects. I got out about 10 gallons. screen had lots of small metal shavings in it. Probably not a good sign other than it shows wear. It is all drained and is waiting for new seals and, filter and oil tomorrow.
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #13 ·
Super55 all fluids, filter and screen changed with JD Hy-Gard and parts. Noise mostly went away but it is still there sometimes. I hope it will be ok but I think I learned an expensive lesson by not checking my rear end fluid!
It will only make a noise at low idle and only some times. if you rev it up and then back down it seems to go away. I am not sure where the noise is coming from if it is the hydraulic pump or something else. I think it has to do with the hydrostat.
 

·
Registered
Joined
·
2,036 Posts
Super55 all fluids, filter and screen changed with JD Hy-Gard and parts. Noise mostly went away but it is still there sometimes. I hope it will be ok but I think I learned an expensive lesson by not checking my rear end fluid!
It will only make a noise at low idle and only some times. if you rev it up and then back down it seems to go away. I am not sure where the noise is coming from if it is the hydraulic pump or something else. I think it has to do with the hydrostat.
did you use hy-gard lowviz? (J20D)
 
1 - 15 of 15 Posts
Top