Green Tractor Talk banner

1 - 4 of 4 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Need help with 47" 2 stage snow blower that is attached to a X728se. The unit vibrates kinda from left to right when the PTO is engaged. Well maintained and lubricated. Has anyone experienced this problem or have a cure? I don't remember have this type of problem with a 47" 2 stage that was attached to a JD 420, which the 728 replace. Any advice or suggestions would be appreciated. Thanks
 

·
Registered
Joined
·
2,563 Posts
Need help with 47" 2 stage snow blower that is attached to a X728se. The unit vibrates kinda from left to right when the PTO is engaged. Well maintained and lubricated. Has anyone experienced this problem or have a cure? I don't remember have this type of problem with a 47" 2 stage that was attached to a JD 420, which the 728 replace. Any advice or suggestions would be appreciated. Thanks
Well your vibration, if like mine is more an oscillation, which to me appears to be related to the auger rotation. This oscillation is increased with an increase in engine RPMs. My prior blower from a different company had this same issue as well. I always thought it was due to a slight bend in the auger shaft. Now mine only does this when raised off the ground. If yours is new (under warranty) and is doing it while on the ground, I would contact your dealer. Mine does not move side to side on the ground. Let us know.:dunno:
 

·
Premium Member
Joined
·
11,023 Posts
Right... same here with my 54" on a 2720. When raised up and engaged the blower kind of does "The Waltz" side to side slowly.

It is completely unnoticeable when on the ground.
 

·
Registered
Joined
·
350 Posts
Here is a thought....

On the older front pto set up like on my older 855, the pto connection was with 2 shafts..
The front short pto shaft from the mounting bracket to the blower had a square shaft and sleeve...
If you separated the two halves of the short shaft and turned one 1/4 turn and re assembled it would not run well if at all..

Because the two U joint yokes would be out of sync and vibrate..

Maybe not all implements and mounting bracket combinations were that way, but some were..
--
If your pto only uses one shaft, and is 3 sided on the telescoping part, a 1/3 wrong turn would be a real vibration issue, I would think..

Good luck..
 
1 - 4 of 4 Posts
Top