Green Tractor Talk banner
1 - 7 of 7 Posts

·
Registered
Joined
·
287 Posts
I searched the shop manual and couldn't find anything on removing the sensing unit from the fuel tank. I did find a section that talks about testing the sensing unit and describes removing to the left rear tail light to get to it. I attached the page from the shop manual for reference. I hope this helps.
 

Attachments

·
Registered
Joined
·
11 Posts
How do you get the fuel sender out of a 4720 with cab?
Ive pulled a few of these out and I could be wrong. Ive always accessed the sending unit from under the floor mat nearest the door...or from a kick plate just below the seat on the left side.
in the last month ive found that its not actually the component thats bad, but the fuse panel, relay or pins being loose on the back side of the fuse panel. I dont know why but it seems quality control looks over these small details.
 

·
Registered
Joined
·
2 Posts
The fuel sending unit is on the top of the fuel tank. The only way to access this is to remove the left rear wheel, then remove the tank. Drain the tank first and remove the 3 main bolts on the top and side. Also remove the bottom plate by the cab step and take out the left tail light. See the photo attached here.
 

Attachments

·
Registered
Joined
·
609 Posts
Is there anyway to test the fuel sending unit before going to all this trouble to make sure it’s not just a broker or loose contact or something?
 

·
Registered
Joined
·
2 Posts
Replacing the fuel sending unit on a JD 4720, 4520 or 4320 with cab.

Here is some advice... If you have an ohm meter, you can test the sending unit and wiring yourself. Disconnect the plug on the sending unit (which is connected near the left tail light. You can test the resistance across the pins. If you do this with the fuel level low enough, then add some fuel to the tank, the resistance should change as the level rises. If it does not, or is open then you have a bad sending unit. Replacing the sending unit is only about a 2-3 hour job. It's not as bad as it looks in the photo.

If the sending unit checks out, the next step is to ohm out your wiring from the sending unit to the gauge. Disconnect both connectors and check it with your ohm meter. Resistance should be very low, with your gauge never moving off empty you may have a broken wire.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top