Green Tractor Talk banner
1 - 2 of 2 Posts

·
Registered
Joined
·
12 Posts
I have a 2015 5085E and my tractor is doing the same thing at certain rpm's. I believe mine is around 16 or 1700 rpm. Below that speed gone above that speed gone. While it's making that noise, I can go around back and the hydro lines leading to the right side of SCV vibrate. It sends a horrible noise into the cab. I don't have my tractor right now, it's getting the dash cluster replaced, but when I get it back I'll try to get a better idea of what's going on and get back to you.
 

·
Registered
Joined
·
12 Posts
Well I got my tractor back from the dealer today. I noticed that my noise happens at almost the same two rpm ranges as you have stated. It is pretty annoying isn't it. I tried moving my joystick around, played with the rear scv controls, tried all float positions, no change in noise what so ever, had No effect. I'm stumped.

But I didn't get anything fixed while it was away. They told me they swapped the cluster and the new gauge cluster did the same thing. They referred to the service manual, and it stated faulty cluster, so they checked with John Deere, and they said that because my differential lock and parking brake were not electronically controlled, that those two lights will not come on. Then why is there an electrical switch on top of my rear end that engages when I put handle to park. Checked it with an ohm meter, and it works, it's tied into the rear harness. Are they screwing with me here? Curious as to wether or not your diff lock and parking light come on.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top