Green Tractor Talk banner

1 - 5 of 5 Posts

·
Registered
Joined
·
389 Posts
Discussion Starter #1
What would make the clutch and power take off arms coming off the transmission act in an interconnected way?

My 5105 has lost the power take off and when the clutch is depressed the rod for the pto linkage is compressed. If the pto is put in the on position the clutch is essentially pushed in most of the way.

I got on it to install a work light I just bought, it had an offset flail mower which I forgot about and snagged the offset end, have a hard time thinking this created the problem. The clutch felt harder as soon as I got on. My help says it was working normally.

Any ideas? is it most likely necessary to take it in half and service the clutches both traction and pto?

The traction clutch seems to work fine but the little lever on the side of the transmission moves as the traction clutch is depressed. I have removed the rod connection for the pto to verify.

I can continue to do hay with a ground powered rake and pull hay wagon and trailer. Would this be ill advised?

Thanks,

Fran
 

·
Registered
Joined
·
389 Posts
Discussion Starter #4 (Edited)
Has this behavior been seen prior and is there any option besides taking the tractor in "half"? Is there anything my help could have done to bring this about or could a shock to the tractor of the offset implement striking something, I was in high range and ripped about an inch off a utility pole, not a hard stop. I removed some of the pto linkage, the traction clutch can have a bit of vibration on slow engate under load. Not much and not always.

Service says 8 to 10 days once it is brought in and put in line. Not as bad as the last time I asked about something.
 

·
Registered
Joined
·
389 Posts
Discussion Starter #5
For those wandering the internet wondering what could have gone wrong with a similar machine, The service manager told me that the pilot bearing went out and took out some clutch fingers. I should not blame my help. I am still kind of confused as taking out fingers and total loss of pto drive must make sound which sure did not happen on my watch. He did not really give me an answer if I could have adjusted it improperly leading to the problem. At any rate I got a new unit with both traction and pto clutch and see 3 bearings on the slip.
 
1 - 5 of 5 Posts
Top