Green Tractor Talk banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I'm needing help in figuring out why my PTO shuts off. I have a 2010 5105M with about 3600 hours on it. I'm running an MX15 brush hog clipping pastures. I will mow for about 45 minutes and then the service indicator light kicks on and my PTO shuts down. I turn it off and back on and that indicator light kicks back on and shuts the PTO down. I have the let the tractor sit for a while turned off before I can get it to work again. Oil level is good, hydraulic oil level is good. I just put a brand new battery in it. It's driving me crazy and my JD dealer hasn't been much help. They came out late on a Friday afternoon and said the diagnostic codes were only showing "low voltages" and that it could be the battery. I replaced it and it still happens. I'm wondering if something is getting hot and causing it to shut down since it works for a while then shuts off.. Anyone seen anything like this?
 

·
Registered
Joined
·
9 Posts
I got a 5100E and this what I have came up with. Do you have a 540E? If so put it in regular 540 an try that. I did that an so so it has worked really good.
 

·
Registered
Joined
·
4 Posts
I have a 2016 5085E. I found out that the seat has a safety switch that will cut off the PTO if I lift my weight off the seat a little, for SAFETY. ALSO, the PTO switch can have burned contact inside and make the PTO drop off intermittently. Same switch is on my ZERO turn commercial mower. Had to change it once with the same problems you are having.
Hope this aids your troubleshooting a little. BTW, the switch is an easy replacement, if that is the issue. I ohmed mine with a meter and found the switch was trashed.
Good luck!
 

·
Registered
Joined
·
1 Posts
I'm needing help in figuring out why my PTO shuts off. I have a 2010 5105M with about 3600 hours on it. I'm running an MX15 brush hog clipping pastures. I will mow for about 45 minutes and then the service indicator light kicks on and my PTO shuts down. I turn it off and back on and that indicator light kicks back on and shuts the PTO down. I have the let the tractor sit for a while turned off before I can get it to work again. Oil level is good, hydraulic oil level is good. I just put a brand new battery in it. It's driving me crazy and my JD dealer hasn't been much help. They came out late on a Friday afternoon and said the diagnostic codes were only showing "low voltages" and that it could be the battery. I replaced it and it still happens. I'm wondering if something is getting hot and causing it to shut down since it works for a while then shuts off.. Anyone seen anything like this?
Did you find the fix for this issue? I am currently having the same problem and would like a little help if you could. Thanks
 

·
Premium Member
Joined
·
7,935 Posts
The low voltage code would make me think, battery cable connections or the contacts inside the PTO switch.
 

·
Registered
Joined
·
972 Posts
Did you find the fix for this issue? I am currently having the same problem and would like a little help if you could. Thanks
If the pto is staying engaged for 30 - 45 minutes before cutting out, I would check the pto solenoid with an ohmmeter. ohm reading should be between 8 - 12 ohms. If it checks ok when cold, recheck it after pto shuts down and solenoid is still warm. If less than 8 ohms, replace it.
 

·
Registered
Joined
·
1,310 Posts
I have a 2016 5085E. I found out that the seat has a safety switch that will cut off the PTO if I lift my weight off the seat a little, for SAFETY. ALSO, the PTO switch can have burned contact inside and make the PTO drop off intermittently. Same switch is on my ZERO turn commercial mower. Had to change it once with the same problems you are having.
Hope this aids your troubleshooting a little. BTW, the switch is an easy replacement, if that is the issue. I ohmed mine with a meter and found the switch was trashed.
Good luck!
my 5105m's pto will run without me in the seat ....just beeps at me as a warning...
 
1 - 7 of 7 Posts
Top