Green Tractor Talk banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
5520 (late model display). Today my hour meter started flashing ALL of the icons. The hours no longer show - just have flashing "boxes" where the numbers should be and the normally unused icons included in the box are now flashing as well. Tractor should have somewhere around 480 hrs on it. I have done numerous forum and google searches but had no luck in specifics. Any tips are appreciated.

ETA: all of the other gauges ARE functioning (tach, temp, fuel). Lights and air function as well.
 

·
Premium Member
Joined
·
10,207 Posts
Strange. Have you checked all the fuses and connections?

Sounds like the display may be malfunctioning, but I could be wrong. I don't recall anything about these tractors flashing trouble codes on the display, but that might be a slim possibility also.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Strange. Have you checked all the fuses and connections?

Sounds like the display may be malfunctioning, but I could be wrong. I don't recall anything about these tractors flashing trouble codes on the display, but that might be a slim possibility also.
Yes, I checked all of my fuses. Some comments from some other folks has me wondering if this could be a grounding issue....???? All other gauges on the panel work.
 

·
Registered
Joined
·
1,129 Posts
Unfortunately, you need a new instrument cluster. That is the only way to get the hour meter to work again. Another alternative would be installing another separate hour meter somewhere else to keep track of hours. If you install a new cluster, the hours will start over at "0", there is no way to program the hours into this model dash.
 

·
Premium Member
Joined
·
10,086 Posts
I would check the voltage of the battery. Low voltage will cause strange issues too.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top