Green Tractor Talk banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 2011 6330 standard. Spent 5-6 hours with 15’ brush hog, cooled it down. Rained next day. Now it cranks and cranks but no try to start. Fuel filters are 6 months old, every spring. Proper pressure at drains on filters. Have been reading about fuel manifold pressure switch cutting off injectors. Just had a terrible run in with the JD service dept about a gator a couple weeks ago and not looking to call them if i can get an idea where to look without being able to hook a computer to it.
 

·
Registered
Joined
·
2,853 Posts
Welcome to GTT
I suggest to check for a blown fuse. I also suggest to check/clean/tighten all four(4) battery cable connections.
Do you hear a "click" from inj pump when ign switch is in 'on position" which would indicate fuel control solenoid is receiving electrical power ? Do headlamps illuminate when light switch is turned on? Check battery voltage with a VOM.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Welcome to GTT
I suggest to check for a blown fuse. I also suggest to check/clean/tighten all four(4) battery cable connections.
Do you hear a "click" from inj pump when ign switch is in 'on position" which would indicate fuel control solenoid is receiving electrical power ? Do headlamps illuminate when light switch is turned on? Check battery voltage with a VOM.
Battery voltage is good, lights, primer pump all come on with key. Haven’t gotten to hear click at injection pump but will look for that. Saw a fuse bank on top, will check those tonight.
thanjs for the suggestions, keep them coming !!!
 
1 - 3 of 3 Posts
Top