Green Tractor Talk banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
hey everyone, this is my first post on this site..

My 8530 (07) has problems with the autotrac steering, when we bought it, it worked fine for over a year, this year we went out to the field again and it threw code SSU 523795.12 (autotrac steering valve fault) which disables the autotrac and show's diagnostic code, so what i did is clear the code and it worked again..sometimes for a day next time only 10 min..so i knew it was something with the steering valve so we put a brand new one on, the code is gone but the tractor wont steer like it did before switching the valve, if i press the Resume button to enable autosteer it will flip the wheel all the way right and gets of about 4 ft. off the line and slowly comes back to 0-1 inch like it should, once its there it steers perfect again, everytime i move the steering wheel to disable or turn around and want to resume autosteer it flips the wheel right and then slowly comes back left.. what could cause this? another sensor? i was thinkin maybe the wheel angle sensor, but not sure..

p.s. i have tried 2 different steering valve electro cotrollers but it still does the same..
 

·
Registered
Joined
·
2,480 Posts
I just wanted to welcome you here and say glad you found us. We have some very knowledgeable techs that will probably lend you a hand shortly.:wgtt:
 

·
Registered
Joined
·
1,058 Posts
Sounds like you need to recalibrate the ssu and also recalibrate the steering angle sensor. Both of these need to be done to wrk correctly with new auto trac valve.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Sounds like you need to recalibrate the ssu and also recalibrate the steering angle sensor. Both of these need to be done to wrk correctly with new auto trac valve.
Thank you.. before i forget to mention, before we put the new steering valve on the tractor, we removed and cleaned the old one and put it back on to try it and it did the same thing, like it does with this new valve.. it started when we removed it the 1st time, maybe something dirty got it when removing it?

To recalibrate the ssu does a JD dealer have to do it?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Yes, a dealer will need to recalibrate.
I know theres some kind of calibrate mode on the greenstar 3, WAS CAL and Valve CAL that you can do yourself, but i have the gs2 2600 model, can it somehow be done with that too? i dont really like my local JD thats why im tryin to do this myself! ive been looking everywhere to find a CAL mode but all i find is for the GS3..
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
I know theres some kind of calibrate mode on the greenstar 3, WAS CAL and Valve CAL that you can do yourself, but i have the gs2 2600 model, can it somehow be done with that too? i dont really like my local JD thats why im tryin to do this myself! ive been looking everywhere to find a CAL mode but all i find is for the GS3..
did calibrate on SSU 028 but still does it, put a new Flowmeter sensor in, nothing, they said it might be a bad steering valve, gonna try that, hopefully solves the problem!
 
1 - 8 of 8 Posts
Top