Green Tractor Talk banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 926 John Deere Moco that I just had both cylinders rebuilt on the cylinder on the left with the two spouts has one hose going to l the other cylinder on the right but it is not raising the right hand cylinder what could be causing this problem? I've tried to blow out the line to see if maybe it was clogged and it was okay.
 

·
Registered
Joined
·
2,699 Posts
i recently rebuilt the right single hookup cylinder on my 630 (same setup as yours) and had no issues but both cylinders are single acting with no return........i suspect your right cylinder hose and line have no oil in them and no way to get oil except what bleeds by the left cylinder seals .....so i would do a oil fill on the right cylinder and hose and then cycle it several times to push out any small amounts of air left.

specificly i would jack up and block up the moco so both lift cylinders were fully extended with no weight on them ....then with both extended i would unhook the hose at the top of the right cylinder and pour fluid in the top of the right cylinder and fill it....and pour fluid in the hose and fill it ...reconnect and then cycle several times under load ....

be safe and i hope this makes sense
 

·
Registered
Joined
·
7,764 Posts
👆Good advise. We have a 820 and blew a hose on ours and had to fill the right cylinder afterwards as air is hard to bleed in this setup. We had to cycle several time before they both started raising equal.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top