Green Tractor Talk banner
1 - 11 of 11 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a John Deere 950 with front loader. I was moving some machinery into my new shop the other day, using the FEL and pallet forks on the 3 point hitch.
Everything worked fine. I took a water break, came back and the 3 point wouldn't raise at all.
Front loader and power steering work fine.
I checked the fluid, it is full and clean. Fluid was changed just before I bought it, about 4 months ago, and filter changed/screen cleaned.
Can a 3 point go out just sitting there, not even running, with no load on it ?
Looking for places to start trouble shooting. Suggestions gladly accepted. Thanks.
 

·
Registered
J.D 2038r
Joined
·
610 Posts
Welcome to GTT from NW Ct.
 

·
Premium Member
Joined
·
10,383 Posts
Welcome to GTT.

You might want to edit the subject to describe the model and issue. More people will reply to it.
 

·
Senior GTT Super Slacker
Joined
·
45,909 Posts
Welcome to GTT
 

·
Registered
Joined
·
3,509 Posts
Welcome from west central Wisconsin.
 

·
Registered
Joined
·
5,522 Posts
@SRG has a brain full of info on that model.
He'll be along shortly I'm sure.
@ridesdirt is another .
 

·
Premium Member
Joined
·
1,466 Posts
Welcome from SC

I had problems with the 3 point on a 750, it was completely unpredictable. I was never able to figure the problem out, I was pushed for time and found a complete rockshaft assembly out of a salvage yard. My rockshaft had been "worked on" and the valving was put together wrong, I believe there were a few pieces missing, so I just replaced the entire assembly.

Your problem is different. I am no tractor tech, but would think you just had a seal fail/blowout. Yours sounds like a relatively easy repair... if you are comfortable tearing into the internal hydraulics. @SRG is the man. Should be pretty easy to find a service manual on eBay or other sources.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #9 ·
Thanks for all,the welcomes. I edited the subject and will wait for the guru's to arrive. I am comfortable tearing apart mechanicals and confident I can put them back together properly. I however do not have any high pressure experience or gauges. I will wait to see what the pros advise. Thanks again for helping.
 

·
Super Moderator
Joined
·
10,537 Posts
Welcome aboard from Massachusetts!

Here's a link to JD Parts which might be helpful: 950 Hydraulics

I'm guessing you may have a rockshaft linkage, control valve or piston seal issue. These are fairly easy to repair.

Linkage:

Slope Font Parallel Auto part Schematic


Control Valve:
Rectangle Font Slope Parallel Pattern


Rockshaft Housing:

Motor vehicle Font Auto part Art Circle
 
1 - 11 of 11 Posts
Top