Green Tractor Talk banner

1 - 12 of 12 Posts

·
Registered
Joined
·
75 Posts
Discussion Starter #1
So I'm very happy with my x584 and have just under 2 hours on it. When I finished mowing yesterday I noticed that my instrument cluster was cloudy. I thought maybe it just had an oil smudge on it but when I tried to clean it off it wasn't having any effect on it. There is very little humidity out here now that it's fall. I'm sure there must be some moisture that has gotten in (haven't ridden it in the rain, and it's stored in a dry shed). I didn't didn't appear until the end of my mowing (about 40 minutes). It's rather annoying to not have a clear instrument cluster (also being that it's brand new). Has anyone else experienced this? Any quick remedy for it? I'll see if I can get some pictures of it.

For illustration it looked very similar to this (position and blur).
screenshot_09-24-2018 14h35m_08s.png
 

·
Premium Member
Joined
·
12,102 Posts
Unfortunately it is normal. The previous dash with just the hour meter clouded up the same way. My X500 does it all the time and it is stored indoors and never left out in the rain.

It should clear itself after a while.
 

·
Registered
Joined
·
620 Posts
Almost 50 hours on my 580. Washed it twice with hose, driven it in the rain, store it in a shed, and we've had plenty of rain. No problems at all. Call the dealer.
 

·
Registered
Joined
·
620 Posts
Obviously a defective LCD. So why did you wait so long to contact the dealer?
 

·
Registered
Joined
·
75 Posts
Discussion Starter #7
Obviously a defective LCD. So why did you wait so long to contact the dealer?
lol, I went from reporting this at 1.8hrs to now 2.5hrs (It's been raining almost everyday here, so I havent used it much in a few weeks). Warranty goes for 4yrs/400hrs... Hardly waited that long to report it.
 

·
Registered
Joined
·
620 Posts
lol, I went from reporting this at 1.8hrs to now 2.5hrs (It's been raining almost everyday here, so I havent used it much in a few weeks). Warranty goes for 4yrs/400hrs... Hardly waited that long to report it.
I get your point, but just thinking if it were me, and with hours on the tractor, I would have at least called the dealer, asked if they had the display module in stock, that sort of thing. Good luck with the fix.
 

·
Registered
Joined
·
75 Posts
Discussion Starter #9
Tractor is coming back from the dealer today. They said they haven't see a lot of it but JD was aware of it. We'll see how it goes with the new display.
 

·
Registered
Joined
·
75 Posts
Discussion Starter #10
They should have set the hour meter to the number of hours on my tractor correct? It looks like they just skipped that installed it and set it out with 0.0 hours! Guess I have to remember that now for all of my service intervals. I had 3 hours on it, so not the end of the world but I thought I would have that at least.
 

·
Premium Member
Joined
·
12,102 Posts
They should have set the hour meter to the number of hours on my tractor correct? It looks like they just skipped that installed it and set it out with 0.0 hours! Guess I have to remember that now for all of my service intervals. I had 3 hours on it, so not the end of the world but I thought I would have that at least.
I don't think they have the ability to do that. If you get a new instrument cluster or a new hour meter (older models) the count goes back to zero.
 

·
Registered
Joined
·
75 Posts
Discussion Starter #12
I don't think they have the ability to do that. If you get a new instrument cluster or a new hour meter (older models) the count goes back to zero.
Got it, I thought it was a simple thing they did. I guess not. Oh well, just add 3hrs. I'll have to see how it does this weekend.
 
1 - 12 of 12 Posts
Top