Green Tractor Talk banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a MY2011 4720Cab, and the engine temp has run 3/4 (between mid and red) no matter work load or outside temp since I've owned in (has 65hrs) now. I did the first at 50hrs did detail clean and replaced the collent.

I had a 3720 cab with a Yanmar engine and the temp gage never got past 1/2 way.
 

·
Premium Member
Joined
·
971 Posts
My 4520 is the same way. It makes it look like it's running a little towards the warm side. I'll take a picture of it next time I'm doing something. The temperature does not seem to change as I do stuff, or with the outside temperature so I know the system is working correctly.

It's odd how one would be more comfortable with gauges (temp, current draw) that are set up so that the midpoint on the gauge is the nominal operating position....

Pete
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Pete:
thanks for your reply. I've noticed that mine will show this temp (between 1/2 and red area) even if it just sits there running...however, once warmed up to this point, it does not move no matter how hot, running the A/C full blast and brush mowing...my guess is that we're okay, but it's good to hear others experences.
Mike
 

·
Premium Member
Joined
·
3,564 Posts
If you search back Mike, you will see that I made the exact same post when I moved from my 3720 to my 4520. Its normal. :thumbup1gif:

It takes a while to get used to it!
 

·
Registered
Joined
·
48 Posts
One thing to remember is that the 3x20 series have Yanmar engines and the 4x20 have 4 cyl Deere engines. My 4720 also runs in the 3/4 range as you all describe.

John
 
1 - 6 of 6 Posts
Top