Green Tractor Talk banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1,092 Posts
Discussion Starter #1 (Edited)
Last nite I nite I noticed my Dealer installed LED lites were out. All other lites worked. Called dealer, he said they had no road tech but they would pick it up. I told him I would look at it a little and if no fix than pick it up. I unplugged the led's and a new fuse blew, I unplugged the feeders at the bottom of the ROPS and another new fuse blew. Figured I would check the switch. unbolted the dash, unscrewed the cruise and brake handles and lifted the dash, took out the switch. Switch was good. I think it's the feeder wire harness between the dash and ROPS but stopped. At that point I decided to let the dealer fix it. I'm not going to dismantel the full dash and floor boards to chas a wire fray, crush or faul.

Question is, when I unscrewed the cruise lift hande, it came off but the linkage arm shot downward. When I put everything back together that linkage arm was a PITA. it now has a lot of slop and doesn't feel right. No spring tension when I pull it up and handle doesn't seem to screw into linkage arm clip tight to plastic dash shroud. Can anyone with a 1025, pull the cruise up then push a pedal and see if it has spring tension against the upward position. I looked very where and couldn't find anything that might have fallen off linkage arm and linkage arm clip. Emailed dealer and asked him to check that when it goes in for LED trouble shooting.

Would appreciate any help. Just got a new tractor, starting to feel like I brought a boat !
 

·
Registered
Joined
·
2,840 Posts
Provided your dealer isn't a boob, they will fix it up for ya. Those are small potatoes. If the drive train stopped workin, we'll then I would worry.

Sent from my SM-N910V using Tapatalk
 
  • Like
Reactions: johnH123

·
Registered
Joined
·
386 Posts
Mine was similar when I took the dash apart to do my rio fix but I just left it. Would personally never use it anyway.
 

·
Registered
Joined
·
1,092 Posts
Discussion Starter #4
Don't have service manual

Does anyone know how the cruise control linkage is properly hooked up ? I know it's tension loaded and know it just freely goes up and down. It actually works but would like to get it back the right way. Would really appreciate if anyone has a service manual and can take a glance. Dealer will probably fix it when it goes in for service but I want to add a switch down the road in that spare blank on the lower left of dash. Don't want to repeat my problem. Know it's minor but it annoys the s$&t out of me every time I operate my Week old rig. Part that's driving me nuts is I'm mechanically inclined and do a lot of restoration and I can't find any linkage piece that came off and is hanging somewhere. Don't want to dig further with it going back to dealer to fix short in lighting circuit.

Thanks,
Don
 

·
Administrator
Joined
·
18,282 Posts
Don,
You can look in JDP yourself and get these drawings-not sure if it's what you need though:
0001129136____________A1.jpg


Cruise Control

CartkeyPART NO.PART NAMEQTYSERIAL NO.REMARKS
1LVU24258Linkage1
2M139927Knob1
3M147595Screw1
4M157953Coupling1
5LVU22263Bushing1
6LVU20821Round Retainer1
703M7191Bolt1M10 X 25
824M7088Washer26.600 X 12 X 1.600 mm
9M112711Spring Pin1
 

·
Registered
Joined
·
1,092 Posts
Discussion Starter #6
Thanks Ken

Looks like there might have been a spring that seats in that upper square lobe or cam on part 6. Gotta look an the floor and in my mower deck again. Thanks again Ken.
 
1 - 6 of 6 Posts
Top