Green Tractor Talk banner

1 - 3 of 3 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hello,

I just picked up a used M044SBH blower for my D140 tractor. Everything is working great except for 2 things:

1) The bolts that are used to adjust the height lever are completely rusted and I cannot adjust them appropriately. I found some parts on the JD site, but it looks different in the graphic. Wondering if I'm searching for the wrong thing or something. Anyways, I attached the photo.

2) It seems like it takes some effort to get the blower going. According to the manual, engage PTO in low idle, then ramp it up. I do that and it hangs for 2-5 seconds at the high throttle before the augers engage. There was some rust on the blower, so I'm wondering what to grease/look at to make sure I don't blow up my mower!

I don't have the manual unfortunately (craigslist deal), but otherwise the blower looks in awesome condition.

Any help would surely be appreciated!
 

Attachments

·
Super Moderator
Joined
·
5,196 Posts
Your blower is actually off of an older machine. It's close but it was designed to be mounted on the older "L-1xx" series riding mowers. They changed the design slightly with the D-100 machines and they've also changed some parts over time depending on the blower serial number. The only ones that use the eyebolt shown all have a serial number below 020000.

Anyway, the part number you want for the eye bolt is M155451, the nut on it is 14M7152 and the locknut is 14M7517. Obviously if you want to replace both sides you'd need two of each. The nut and locknut are both 10mm so you may be able to source those elsewhere easily enough.

If you go to JD Parts and search on a L100 mower, the Snowblower will come up in the breakdown list. You can expand that and find all the parts for your blower.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
Thanks a lot Jim. I appreciate the information. Before purchasing, I called my local JD dealer and they assured me that everything would line up and it does. Hopefully everything works just as well :) Its going to snow this week, so I'll get to test it out. I just cant get the mower in the shed without raising that blower up!

I'll have to check out why it seems to be hard for it to get going. Probably could use a greasing somewhere.

I'll check out the JD parts now! Thanks again.
 
1 - 3 of 3 Posts
Top