Green Tractor Talk banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I'm trying to solve an electrical issue on my elderly neighbor's 990. She was having issues with the starter, so I replaced that, but while I was replacing that she decides to "clean" some of the rat nest debris around the dash. Now with a brand new starter and battery cables/terminals, I fear she probably disconnected or shorted something along the wiring causing the circuit to lose voltage somewhere. There were a couple of gnawed wires I cleaned up and spliced with clean butt connections, but now I'm at a stand still.

I think there's an issue within or beyond the TDCM because of the following:

There's a 10v drop when the TDCM is connected; could the voltage drop be the TDCM or a component/wiring to one of the components it connects to?

The work I've done thus far:
- Replaced positive and negative battery leads & terminals and the battery has 12.8V.
- Installed new starter/solenoid.
- Has 12.8V from starter terminal to ground.
- Has 12.8V at power supply from starter to key switch with key in "OFF" position.
- Has 12.8V at power feed to the rest of system at the key switch circuit with key in "RUN" position.
- PTO, Neutral Switch, seat switch, light switch, rectifier, and fuel shut-off relay are not causing voltage drop.
- Will get 10.5V to fuse box with key in "RUN" position and TDCM disconnected.

If I unplug the TDCM and measure voltage along the connected circuit it will read 12.8V up to the fuse box with the key switched to "OFF" position. With TDCM still disconnected, and the key switched to "RUN" position, the battery light on dashboard will illuminate, and the PTO brake light will blink, showing a voltage of 10.5 to 9.5V (as the two lights with one blinking is causing this voltage drop). Once TDCM is reconnected to circuit, the voltage drops to 2.1V.

The voltage will remain at 2.1V with the rear wiring harness disconnected (which includes PTO, Neutral Switch, Seat Switch).

Any suggestions? Is there any way to test the TDCM? how often do they go bad? Should I just get a new wiring harness?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
Solved the issue. Apparently the negative battery cable I replaced wasn't connecting to the terminal or ground very well because of the stock components on the new cable. I found this out after connecting a pair of jumper cables from battery to ground and the engine turned right over. Wiring is such a pain in the butt.
 
1 - 2 of 2 Posts
Top