Green Tractor Talk banner
1 - 5 of 5 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
Hi, yesterday my PTO won't engage. The computer is tossing error code 5-6. Machine is 2011 997 Ztrak with 560 hrs on it.

If anyone could post this code text, I'd appreciate it.

Thanks in advance,

G
 

·
Registered
Joined
·
5,322 Posts
Hi, yesterday my PTO won't engage. The computer is tossing error code 5-6. Machine is 2011 997 Ztrak with 560 hrs on it.

If anyone could post this code text, I'd appreciate it.

Thanks in advance,

G
That is a pto output error. I’m very familiar with that one. Probably the pto switch. The stock one was very crappy. If yours has the push/pull type, you might as well replace it with the upgraded rocker switch. I have a thread on in from a couple years back, and there has been allot of discussion on it over the years. The new switch upgrade fixed my problem after 3 push pull switch replacements
 
  • Like
Reactions: Brucey and gdow

·
Registered
Joined
·
17 Posts
Discussion Starter · #3 ·
Thanks for the code description. I pulled the pto switch and tested it, it tested ok but over the years of people pulling the plunger up too strongly has damaged it. It should be replaced. I made a temporary switch from a 2 pole circuit breaker and tied it in. Upon attending to engage the pto I received the same error code. So it seems the problem is someplace else in the circuit. I don’t have any wiring diagrams so I’m not sure where the wiring is installed to activate the hydraulic pto.
Gerry
 

·
Registered
Joined
·
5,322 Posts
Thanks for the code description. I pulled the pto switch and tested it, it tested ok but over the years of people pulling the plunger up too strongly has damaged it. It should be replaced. I made a temporary switch from a 2 pole circuit breaker and tied it in. Upon attending to engage the pto I received the same error code. So it seems the problem is someplace else in the circuit. I don’t have any wiring diagrams so I’m not sure where the wiring is installed to activate the hydraulic pto.
Gerry
[/QUOTE
This should get you started down the right path...
 

Attachments

·
Registered
Joined
·
17 Posts
Discussion Starter · #5 ·
This should get you started down the right path...
Hey, thanks for the download. Its a real big help identifying everything. I found the problem, a cut wire right almost inside the connector ontop leading to the pto. It was not easy to spot, but I spotted it on the second run, reconnected it and the pto engages normally.

Thanks again for the file, i'm sure I'll be needing it again.

G
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top