Green Tractor Talk banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Last week my F525 light it's battery charging light. Voltage at the battery was 12.2+-, and did not change one bit when the engine was running, so I thought OK, dead voltage regulator. New regulator, start the engine and the light goes out. Great!
Except that when you release the parking brake, the battery light comes on.
Break on, no battery light.
Brake off, immediate battery light.
Repeatable, consistent.
Did I bump some wire or something? Safety switch?

Glenn.
 

·
Registered
Joined
·
2,246 Posts
Here's all the book has to say on the subject.





Very helpful.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Yes, hugely so.
However, reading it again, the battery -is- nearly new, I mean... 5, maybe 7 operating hours? Maybe I did not clean the terminals enough or maybe it -is- a dud. I'll have to check those things.
Thanks!
Glenn.
 

·
Registered
Joined
·
1,695 Posts
Is it charging even with the light on? On some of them there was a battery discharge diode. A lil red plastic widget about the same diameter as a nickel and about 1.5 in long. Would be somewhere near the regulator. This will cause the light to come on but it will still be charging.

Sent from my LGL52VL using Tapatalk
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Is it charging even with the light on? On some of them there was a battery discharge diode. A lil red plastic widget about the same diameter as a nickel and about 1.5 in long. Would be somewhere near the regulator. This will cause the light to come on but it will still be charging.

Sent from my LGL52VL using Tapatalk
Interesting! Yes, it seems to be charging. At least in 3 or 4 operating hours it hasn't stopped running and starts fine. I will look for that diode. Thanks!
 

·
Registered
Joined
·
1,695 Posts
Only way to tell is actually measure the voltage at the battery with it running. And measure again with the engine running and the pto on to make sure it can handle the load.

Sent from my LGL52VL using Tapatalk
 
1 - 6 of 6 Posts
Top