Green Tractor Talk banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a problem with my GT 275 which has progressed since earlier this year. On hot days doing heavy mowing it would sputter and lose power but keep running until it would stall. I've been mowing more this year than normal, including with a tow behind trail cutter, and I think I've pushed it too much.
Last week it stalled and wouldn't restart till it had cooled for a good 45 minutes after 2-3 hours of mowing, and today it stalled after just a half hour. Before it stalled there was a hot oil smell but no smoke, and it has been using a little oil but not much.
Any suggestions or thoughts would be appreciated
 

·
Registered
Joined
·
63 Posts
Mowing thru heavy grass and towing something at the same time simply could be the problem. You cannot continue to overheat it, since it eventually will blow a head gasket or melt the piston. But, below is a list of other things that come to my mind:
1. Cooling fins on the head and engine are clogged with dry grass.
2. Carb is clogged and running lean, or fuel pump (if it has one) is running the carb without enough gas causing a lean condition, or a fuel filter is clogged causing a lean condition.
3. Crankcase is overfilled with oil.
4. Spark is retarded.
5. hydro trans - something wrong causing it to bind.
6. Spark plugs are one or more numbers too hot.
7. One or more mower deck spindles are binding, or idler pulley is binding.
8. Engine speed is too low when mowing.
9. Engine air filter is clogged, but usually does not cause overheating.
10. Starter has not fully disengaged the flywheel on startup, causing a drag.

Let us know when you solve the problem. Luck.
 
1 - 2 of 2 Posts
Top