Green Tractor Talk banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi all, new member here,

We have a GX 75 ride on mower that keeps twisting and destroying the mower belt. I guess the drivetrain is out of alignment?

Could anyone advise where I could get information to set up the controls/pulleys/deck?

Thanks...........Joker.
 

·
Administrator
Joined
·
20,466 Posts
:wgtt:


Sent from my phone using Tapatalk.
 

·
Premium Member
Joined
·
1,074 Posts
I'm not familiar with that machine, but have had several 'belt destruction moments' with my mower when I failed to ensure that the belt wasn't routed properly. My 318 drive belt has some studs sticking out of the deck that keeps the belt near the pulley, and sometimes I'll put it on and have the belt outside the stud guide, which will burn a belt up 'pronto'! I'm sure you'll get some seasoned advice, but just wanted to jump in and welcolm you to GTT! ~Scotty
 

·
Super Moderator
Joined
·
2,700 Posts
First off, be sure you have the right belt and one from Deere. Buying a cheap belt from any other source will only lead to problems as Deere specs their belts out and they're made to, not only to a specific length and width, but a specific cross section angle and material. Second check to be sure all pulleys are turning freely and without any wobble. Check to be sure all springs are in place and still have sufficient tension. Check all deck brackets to be sure none has come off or has gotten bent. If one has, then it will throw the deck off, therefore the belt routing. Check to be sure your deck spindles are tight and the bearings are not shot. Check to be sure none of the pulleys are bent or worn out, including the one off the engine. Check for any debris like twigs or anything else that might throw the belt. If all this checks out, then it's time to consult the dealer, or at least, get the service manual.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
Hi all and thanks for the welcome,

T-Mo, thanks for the info. Firstly the belt is not John Deere it was an automotive belt, same size & profile, but i'm guessing now that this could well be the start of the problem.

Couple of things to mention.....when the PTO lever is pulled back there is what I can only describe as a "metal bar" which swings toward the big pulley at the front. The bar keeps going till it touches and burns up the belt. There appears to be very little clearance between this bar and the pulley.

When the mower deck is lowered to it's lowest setting, the belt "Twists" on this same pulley and attempts to throw itself off. This happens when the PTO lever is forward.

Could these be down to the belt?

Cheers............Shaun.
 
1 - 6 of 6 Posts
Top