Green Tractor Talk banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
I have a 1023E equipped with the H-120 Loader and 54" Auto attach mowing deck. Purchased it new in July 2012 and now has 27.5 hours on it. Just installed the loader this morning and noticed that one of the castings that holds the parking stand is broke and the other is cracked. Anyone else having issues with this? I have not talked to my dealer yet, but plan to in the near future.
 

·
Registered
Joined
·
479 Posts
Use the search tool and you'll find a lot of other info about this problem from other threads. To boilerplate: a new stand exists that doesn't use those castings, and your dealer should replace it under warrantee
 

·
Registered
Joined
·
446 Posts
I have a 1023E equipped with the H-120 Loader and 54" Auto attach mowing deck. Purchased it new in July 2012 and now has 27.5 hours on it. Just installed the loader this morning and noticed that one of the castings that holds the parking stand is broke and the other is cracked. Anyone else having issues with this? I have not talked to my dealer yet, but plan to in the near future.

First of all, Welcome to the forum Skip. Here's a link to the much talked about stand issue. I bought my 1023E at the same time you did and had the casting break also. I would call your dealer now to get it fixed.

http://www.greentractortalk.com/forums/sub-compact-utility-tractors-scut/3300-h120-loader-parking-stand.html
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Update on H-120 Loader stand issue

I have a 1023E equipped with the H-120 Loader and 54" Auto attach mowing deck. Purchased it new in July 2012 and now has 27.5 hours on it. Just installed the loader this morning and noticed that one of the castings that holds the parking stand is broke and the other is cracked. Anyone else having issues with this? I have not talked to my dealer yet, but plan to in the near future.
I just visited my dealer and there is an updated stand for this loader. The update does not use the castings that are the problem, and really a poor design. They have ordered the new stand and will be in middle of next week. I looked at some new loaders that they had in stock and it is definitely a change that will correct this problem. I appreciate everyones responses and now I know why I have been brand loyal to John Deere since my early years growing up on th farm.
 

·
Registered
Joined
·
150 Posts
I just visited my dealer and there is an updated stand for this loader. The update does not use the castings that are the problem, and really a poor design. They have ordered the new stand and will be in middle of next week. I looked at some new loaders that they had in stock and it is definitely a change that will correct this problem. I appreciate everyones responses and now I know why I have been brand loyal to John Deere since my early years growing up on th farm.
Did you have to bring the tractor to the dealer to have them asses the problem?
Are they replacing the stand at their cost and do you know the cost and part number of the new stand?
I have yet to break the casting but it seems only a matter of time and the interference problem makes it hard to mount the mower as it tends to push it away as you drive up to it. I have been told I must bring the tractor in or they will do nothing.
It is a 120 mile round trip and I have to rent a trailer so it may be cheaper for me to just buy the new stand out of pocket and have it shipped to my home.
DSCN1288 (Copy).JPG
 
1 - 6 of 6 Posts
Top