Green Tractor Talk banner

1 - 14 of 14 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello everyone,
I am a long time John deere user. And long time member of this forum, I've just never posted.

The first mower I ever used when I was about 13 was a Deere 160. It looked kind of like this: 29017099_large_1569868727201.jpg

Years later my parents bought an Lt166 which served us well until my dad bought a swisher ztr around 2008. After I moved out and bought my own house I took the lt166 with me and it's served me faithfully for the past 8 years.

Just recently I had the chance to purchase a friend of mines old z445.

20190927_194917_1569869129046.jpg
I say old only becuase it is a 2008 / 2009 model, condition wise it is very new. It has about 140 hours on it but it looks closer to 25. It's in that good of shape. Unfortunately he left it sitting for the past 4 years which destroyed the carburetor. I've spent the past 2 months rebuilding the entire fuel system in my spare time and finally got it running last week. It mowes like a dream. All the work I've done has renewed my interest in tractors and lawn care so I hope to frequent this forum.
 

·
Premium Member
Joined
·
9,661 Posts
:wgtt:

My first John Deere was a LT166. :good2:
 

·
Premium Member
Joined
·
13,612 Posts
:wgtt:
 

·
Registered
Joined
·
558 Posts
:wgtt:
 

·
Senior GTT Super Slacker
Joined
·
37,759 Posts
Welcome back davidg716. :thumbup1gif:
 

·
Premium Member
Joined
·
14,870 Posts
Welcome from Preston County, West Virginia

:wgtt:
 

·
Super Moderator
Joined
·
5,576 Posts
:gtfam:
 

·
Administrator
Joined
·
20,845 Posts
David,
:wgtt:
 

·
Registered
Joined
·
4,468 Posts
:wgtt:

Welcome from New York.
 

·
Registered
Joined
·
4,481 Posts
Wow! First post since October, 2012. Welcome ... finally! :lol:
 

·
Registered
Joined
·
3,403 Posts
Welcome from central Ohio :wgtt:
 
1 - 14 of 14 Posts
Top