Green Tractor Talk banner
1 - 20 of 21 Posts

·
Registered
Joined
·
286 Posts
Discussion Starter · #1 ·
784782

784779

784780

784781

I need help identifying parts of my hydraulic pump. The motor suddenly ran faster as if there is no load and the cylinder stopped being responsive.
I'd like to tear-down the least amount of parts.
The splitter quit moving on a laughably very small log.. something most people wouldn't have split.
However, it's seen numerous stressful knotty splits in it's long life.

What is the brown box on the left?
What is the light grey box in the middle?
Which part do you believe failed?
 

·
Administrator
Joined
·
22,955 Posts
I would check the coupler that connects the engine to the splitter, it may be just loose or broken.
 

·
Registered
Joined
·
286 Posts
Discussion Starter · #8 ·
784791

784792

784793

Thanks, guys. I apparently didn't get my as low as I thought. That grey box was accessible from the bottom for a view. I probably would have unbolted the red circle. Appreciate the help!
 

·
Super Moderator
Joined
·
6,999 Posts

·
Super Moderator
Joined
·
6,999 Posts

·
Registered
Joined
·
1,385 Posts
It's just another anti vibration coupling. There are hundreds of different types in the mechanical world. LV being the most popular. My concern is that the pump seized up or the halves got out of alignment. I don't usually see the couplings blow up like that if the rubber just wears out.
 
1 - 20 of 21 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top