Green Tractor Talk banner

1 - 15 of 15 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi,
I am having a problem with the hydraulic lift on my 2011 x534. It was working fine and now I can't get it to go up or down. When I lie under the tractor I can see the lift shaft go back and forth but nothing happens. Also the height adjustment lever turns all the way around and doesn't appear to be functioning. Any help would be greatly appreciated.

thanks!
 

·
Premium Member
Joined
·
1,194 Posts
Does the deck seem like it is stuck up? If so, I would suspect the adjustment knob is the main issue.

Here is the parts involved.

You might remove the deck to watch the arms go up and down as well to make sure nothing is in a bind. If its stuck in the up position or something.
 

Attachments

·
Administrator
Joined
·
20,468 Posts
Welcome to GTT!

Here's a WAG but it sounds like the height adjustment has the deck locked in the up position. Try raising the deck all the way and then turning the height adjuster cam underneath the tractor by hand. Once the deck is lowered, you'll need to find what's broken on the height adjustment system. Be careful not to get hurt.:hi:

:wgtt:
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
Thanks for the quick responses. So I can see the cam shaft slide back and forth but nothing happens. The lift arms do not move at all. I currently have nothing installed on the tractor. I was in the process of putting on the mower deck when I found the problem. When I turn the lift adjustment knob the metal plate underneath does in fact turn but as i said it turns all the way around. I too suspect it is something to do with that which is causing my problem. I guess I'll have to have the dealer take a look.
 

·
Premium Member
Joined
·
1,194 Posts
Are you sure the lift arms will drop without weight? I thought it took weight to get it to work.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
This is a great question, you might be onto something. I was trying to lower the arms when i was installing the mower deck. So in order to install the deck I'll need to lift it up to get it to pin into the 2 arms. I guess i could try that and see if it works. I was thinking I should be able to line it up and lower the arms into position. I guess not?
 

·
Premium Member
Joined
·
1,194 Posts
Yea I dont know. You shouldnt have to lift the deck up. I would think you should be able to set the knob to 1 and pull down on the arm. I had a 345 which was the predecessor to yours and I dont think the arms dropped very easy.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #8
I think I tried to pull down on the arms with no luck. But i will try it again tomorrow. I'll let you know how i make out. Thanks for all the help.
 

·
Premium Member
Joined
·
1,194 Posts
The decks install really easy if you have concrete. Dont worry about putting the belt on or the front draft rod. Just slide it under and hook the back. See if it lifts up and down. Might need worked a few times !
 

·
Registered
Joined
·
280 Posts
those arms do need weight to drop... to get them to drop if you push one side up and "slam" it down a couple of times they should drop down.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #11
Thanks for all the responses. I did indeed solve my issue. Correct you need weight to drop the arms, recall the deck is hydraulic lift and not hydraulic down. I just got the tractor last fall so I haven't used it a ton. Exciting no snow this winter in the northeast. My previous tractor (1990 toro 520H) had a hydraulic lift system both up and down, so you could apply down pressure. That isn't the case with the X534, hydraulic up and gravity down. Just something I need to get used to.

So to solve my problem I just held the lift lever down and pulled hard on the arms and it pulled them down. I got the mower installed and ready to go.

Again, thanks for the responses.
 

·
Premium Member
Joined
·
1,194 Posts
They might loosen up as well. I never had to lift my deck up to attach but remembered the arms didnt drop easy either !

Glad you got it going.
 

·
Administrator
Joined
·
20,468 Posts
Thanks for all the responses. I did indeed solve my issue. Correct you need weight to drop the arms, recall the deck is hydraulic lift and not hydraulic down. I just got the tractor last fall so I haven't used it a ton. Exciting no snow this winter in the northeast. My previous tractor (1990 toro 520H) had a hydraulic lift system both up and down, so you could apply down pressure. That isn't the case with the X534, hydraulic up and gravity down. Just something I need to get used to.

So to solve my problem I just held the lift lever down and pulled hard on the arms and it pulled them down. I got the mower installed and ready to go.

Again, thanks for the responses.
I remember the 520H. It was WheelHorse's flagship tractor. What a fine machine that was!:thumbup1gif: I really like WheelHorses, especially before Toro bought the line. It took Toro a few years to totally screw up the name brand. What a shame.:thumbsdown:

Glad to hear you got your machine working!:good2:
 

·
Registered
Joined
·
280 Posts
glad you got it figured out
 

·
Registered
Joined
·
8 Posts
Discussion Starter #15
Indeed the 520H was a great tractor. Only went away from it because I felt I was running on borrowed time and kind of got sick of the repairs needed on a 1990 tractor. Here is a couple of pics:

P1040402.jpg

1990 Toro Wheelhorse 520H 2011-04-20 001.jpg


Here is the new tractor:

IMG_0930.jpg
 
1 - 15 of 15 Posts
Top