Green Tractor Talk banner
1 - 11 of 11 Posts

· Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
This is my first post, so please direct me if I posted in the wrong area. I had trouble starting my LA130 riding mower, so replaced the battery. Still no start, so I ordered a replacement aftermarket ignition switch & just put it in. I unplugged a set of wires that were hanging in the way. When done, I plugged the wires into the ignition switch and plugged in the wires I had disconnected. Mower started right up, but now there's smoke coming out the front of the mower. Any suggestions what may have caused that? This mower never smoked before.
 

· Premium Member
Joined
·
17,466 Posts
What kind of smoke? Blue oil smoke? white gasoline smoke? Electrical wires burning smoke?

What does the smoke smell like?
 

· Premium Member
Joined
·
17,466 Posts
can't smell anything most of the time, so I can't tell what kind of smell. When I started it, it sounded rough. Now it wont start.
Hmmm... smoke out of the muffler shouldn't have anything to do with changing the ignition switch. You mention it now won't start. Does it crank?
 

· Registered
Joined
·
3,511 Posts
No power to a fuel solenoid at the float bowl maybe?
 

· Premium Member
Joined
·
17,466 Posts
Yes, It just won't turn over & start. So weird. It was running fine... I change out the ignition and bam... problems.
I'm still unclear. Does the engine turn over with the starter? Most refer to this as "cranking" The engine cranks with the starter and then STARTS and runs. Is it cranking and not starting or is it not cranking (i.e. no engine movement)?
 

· Registered
Joined
·
779 Posts
Does it have a separate choke cable? Maybe the adjustment got out of wack while changing the switch.
 

· Premium Member
Joined
·
21,060 Posts
Are you sure you put the wires you removed , back on the pin position you removed it from. ???
or did one of the wires work loose since it won't turn over and start.
 

· Registered
Joined
·
5 Posts
Discussion Starter · #11 ·
Thank you all for trying to help. I called a professional to come look at it. He started it up, a little bit of white smoke came out and then stopped. He couldn't find anything wrong with it at all, so had him do some maintenance and give me a new blade. Not sure why it was acting like that for me.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top