Green Tractor Talk banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi I have a JD 325 Skid Steer 2006 wheel. Engine starts ,Boom and bucket work, unit will not move.Any suggestions where I should start to find the problem?
Thanks in advance
Bob
 

·
Premium Member
Joined
·
3,565 Posts
I am not familiar with that model, but start simple. Any safety switches that might stop it from moving? Is the hydraulic oil full? Are the linkages connected?

Does it have a warning light on the dash flashing?
 

·
Registered
Joined
·
490 Posts
It defiantly would come down to a safety switch or fuse. It could be your seat switch, I would check that connection as well as the wiring. If the boom and bucket works then i doubt it would be low on hydro fluid but it is worth looking at. The fuse box is located to the right of you when you sit in the seat of the 325, it has 1 screw holding the cover on (be careful when putting the screw in, that cover can be tight and you can launch that tiny screw by accident and loose it). I had the fuse to my ignition switch go out on my 317, basically the key did nothing, no start, no gauges, nothing.. I'd try these and see what you come up with.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
It defiantly would come down to a safety switch or fuse. It could be your seat switch, I would check that connection as well as the wiring. If the boom and bucket works then i doubt it would be low on hydro fluid but it is worth looking at. The fuse box is located to the right of you when you sit in the seat of the 325, it has 1 screw holding the cover on (be careful when putting the screw in, that cover can be tight and you can launch that tiny screw by accident and loose it). I had the fuse to my ignition switch go out on my 317, basically the key did nothing, no start, no gauges, nothing.. I'd try these and see what you come up with.
Electrical wire. Thanks Bob
 
1 - 5 of 5 Posts
Top