Green Tractor Talk banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I have a X540 mower and have added the 14 bushel bagging system. I can run it until the hoppers are full and the mower chokes down and the fill indicator will not move. I have put the hose in different locaitons without any improvement. Anyone have any ideas how to make the fill indicator work.
 

·
Registered
Joined
·
2,160 Posts
It should be working off a pressure differential, like a manometer. Make sure the tube and outer sensing tube are not clogged. If its a bellows type of sensor, it may have lost its seal/integrity.
You can do an easy test by blowing into the high pressure (duct)side and see if it moves. The pressure in the duct/tube should be the same anywhere along the duct,unless it has a clog. I wouldnt install it next to the blower to avoid turbulence
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
I checked the mechanism by blowing into it and it works fine. The chute has a hole for the rubber tube to go into and that did not work. I have tried several different locations and the fill indicator just does not move.
 

·
Registered
Joined
·
3,554 Posts
I have the same indicator on my 7bu. PowerFlow... It's just the cutest little piece of colorful tractor fluff I've ever seen! It NEVER worked once since '04. Packed with maple leaves or pine needles, it just sat there. Now it just sits there with a teaspoonfull of water in it... I believe that anybody that's used a PowerFlow for a spell can tell when the hopper is full anyway by the sound of the deck and the way the deck converts itself to "mulching" instead of picking up. But it was a nice try!:laugh:
 
1 - 5 of 5 Posts
Top