Green Tractor Talk banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I drove my JD 333g on some 6X6 so i could do a full maintenance(fuel,oil and hydraulic filter change) on it. I had the boom and bucket all the way up so i could lock the boom on the raised position. as i clime on the 6x6 (under tracks)the engine stalled. i was able to restart and position the tracks on 6x6. i went then to change all the filters. after all maintenance the machine is not moving at all. the hydraulic seems to be locked up.the hydraulic lock button will not go off and so is the parking break light. on diagnostic menu, it indicates that hydraulic filter and oil pressure are off.
machine has 1400 hours and its a 2018 model. please help!
 

·
Registered
Joined
·
257 Posts
This a compact track skid loader not a vintage garden tractor. So when you hit the parking brake switch the park indicator light turns off? If you serviced it are you sure you didn’t bump a electrical plug or pulled on something if you had the ROPS flipped up? Your wording is a little confusing.
 

·
Registered
Joined
·
75 Posts
Is the monitor saying anything about 'cycle lap bar'?

This sounds like an interlock issue. The seat switch, lap bar switch, and door switch must be closed in order for the hydraulics to work and the park brake to release. The service menu (hold down menu button for 5 seconds) will tell you if all these switches are working. Go to the 'diagnostics' menu, then 'switches'. The first 4 menu items should all say 'on' when you're sitting in the seat with the door closed and lap bar down. The 'brake rel' item should say 'on' with the park brake button pressed.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top