Green Tractor Talk banner

1 - 20 of 23 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
My mower on my 425 kept disengaging on its own and I would have to push the PTO switch off and on to get it going again. It also started not disengaging when I went in reverse. Finally I stopped the tractor and once I did it didn't start again. The dash lights came on but nothing. So I replaced the PTO switch, disabled the Brake switch (gray push button attached to the frame) and still nothing. I also replaced the key ignition module. Still the tractor wouldn't start. Finally I checked the battery terminals again and found part of the problem. After making a better connection the tractor now starts BUT the PTO will not engage. FYI - The PTO lights on the dash do not come on.

Any help would be appreciated! I just got it back after 3 weeks at the shop for a hydraulic problem and They can't get to this in less then 2 weeks!!
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
Don't think so as it stalls once I let the weight off but I will jump it anyway. Thanks
 

·
Registered
Joined
·
14 Posts
Discussion Starter #5
I looked for it but couldn't find it. I wasn't sure if it had a separate RIO switch or if it was in the PTO switch it self. Any help locating it would be great.
 

·
Senior GTT Super Slacker
Joined
·
36,593 Posts
AHade, Does this help at all?

MP18273________UN19AUG98.jpg

Reverse Implement Option (070001 - )
CartkeyPART NO.PART NAMEQTY SERIAL NO.REMARKS
1M127370Spring1
2AM120518Switch1070001-XXXXXX
AM104884Switch1XXXXXX-
3M94087Strap1
4M136173Lock Nut2
5M134131U-Bolt1
NLA
6M139087Lever1
7M135529Bolt1
814M7400Lock Nut1
M10
 

·
Registered
Joined
·
14 Posts
Discussion Starter #8
Okay. I guess I have jumped that. I thought that was the brake saftey switch that I explained in the first post (gray push button switch). So maybe there is a brake switch I need to check?

Thanks again for the help.
 

·
Registered
Joined
·
49 Posts
And maybe recheck where you jumped the rio switch to make sure it's getting good connection.


Sent from my iPhone using Tapatalk
 

·
Senior GTT Super Slacker
Joined
·
36,593 Posts
Gizmo that is a lot better response than I was about to try and explain!
:lol: and I have no clue what most of the parts in that picture are.:laugh:
 

·
Registered
Joined
·
49 Posts
It's not too bad, I have to pull all that off this weekend to replace the swash shaft packing (fancy word from John Deere that means 2-orings) to fix my hydro leak.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
14 Posts
Discussion Starter #14
Found it. A little hard to get to it as the deck is on but can't we rule that out as the tractor will not start if the button is not pushed in? Just tried it several times and seems to be working.
 

·
Registered
Joined
·
49 Posts
I would jump it to see. I would jump all the safety switches then see iff it worked, if it does I would rehookup the switches one at a time until I figured out which one was the culprit.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
10 Posts
Have you checked to see if the battery is good. I have seen this issue resolved with a new battery. Systems on JD's seem to like a good battery to function for some reason.

You might want to pull it and take to an auto parts supplier and have them load test it.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #18
Okay so I removed the saftey brake switch, cleaned the connections and replaced it. Now the tractor won't start so I am hoping that this is the problem. There are four wires (as oppose to two on the others). Do you know which wires I jump? There are two blues one green and a brown. Thanks.
 

·
Registered
Joined
·
10 Posts
Okay so I removed the saftey brake switch, cleaned the connections and replaced it. Now the tractor won't start so I am hoping that this is the problem. There are four wires (as oppose to two on the others). Do you know which wires I jump? There are two blues one green and a brown. Thanks.
I'm looking at the harness schematic for a early/late model 425 Brake switch connector and it shows Yellow, Blue, Purple,and Purple....
 
1 - 20 of 23 Posts
Top