Green Tractor Talk banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi all,

Looking for some help with the John Deere closed hydrolic system on my 2020, new to this type of hydrolics and to make matters worst I dont know the year of the machine. In short it started with the 145 loader moving slow or not at all, I changed the o rings on the valve body which helped slightly, I also changed the belly filter however I understand there may be screens I need to clean. I think it is a 1970 and helpful hints?
Wood Motor vehicle Font Grass Gas

Plant Motor vehicle Road surface Grass Font

Plant Motor vehicle Grass Font Tree
 

·
Chief Stick-picker-upper
Joined
·
19,790 Posts
I understand there may be screens I need to clean.

Below the right-side footrest. Item #15 is the transmission sump screen. All hydraulic oil flows through this screen prior to flowing through the hydraulic oil filter.

After draining hydraulic oil, remove plug #13 and washer #14 to access sump screen.


The screen should look similar to this.


It should not look like this. Bad ju-ju.
 

·
Premium Member
Joined
·
3,366 Posts
Welcome to GTT
It appears you have received some excellent advice. It seems like just a short period of time since I sold ""new 2020's"" & frt end loaders.
What type valve controls FEL? If independent control valve does valve resemble control valve in link? If so seal(item 10) is probably faulty.
With hyd oil at operating temp, engine operating/3 pt raised look into open hyd filler hole behind seat for moving/spraying oil. Moving oil indicates leaking seals on rockshaft control valves.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top