Green Tractor Talk banner
1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 · (Edited)
I recently acquired an older JD314 with a Kohler K321 engine that had been moderately maintained over the years. I had been having some fuel issues and I suspected that it was due to dirty fuel that was in the tank when I first got it.

I took some action to try to get it running smoothly which included:

Cleaning/rebuilding the carb - I was sure this was going to be a mess, but it actually was quite clean.
Replaced fuel lines and added in-line filter
Removed gas tank and cleaned thoroughly

I reassembled all of the items and tried to fire it up - it turns and turns but does not start.

I know that the engine is not getting fuel, because as I turn the engine over, I can also watch the inline filter and I can see that absolutely no gas is getting through.

I detached fuel line from the tank and confirmed that the tank valve is NOT closed or blocked. I then removed the other end of the line from the fuel pump and blew some compressed air through the line and confirmed that THAT was not blocked.

I reassembled everything and added some gas back into the tank while all hoses were still attached. No gas appeared in the inline filter after this which I found odd since the tank is slightly higher than the fuel line and fuel pump. I then went and removed the end of the fuel line that is attached to the fuel pump and observed gas move through the filter and drain out the detached end.

Then I reattached the line to the pump (thinking that the air in the line was the issue) and tried again. Still would not start and it did not appear that new fuel was being drawn through the line.

This leads me to believe that my fuel pump is bad or possibly was damaged during my maintenance. I did at one point blow some air through the pump, which seemed to give some resistance at first but then blew through.

This leads me to the reason for posting... I have not taken the fuel pump apart yet and wanted to get some input on possible issues/remedies before doing so. I would rather not have to replace this as it seems that the only available replacements are made of plastic, whereas the one currently attached is the solid original.

What are people's thoughts on this issue, the plastic replacements, or possibly just going with a 'rebuild kit' (which seems to be the same as purchasing a full replacement and only replacing the damaged parts).

I am novice-moderate at small engine work. I am confident in my ability to take apart/reassemble but would rather not grasp at straws if there is a possible issue I am not considering.

Thanks for any help.

Marc
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Thanks Tommy, that will be my next step. You are right, I have already confirmed the filter flow is in the correct direction. Will let you know what I find once I get it apart.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
A quick update...
Took the pump off. Turns out it is a plastic one but was too covered in gunk to tell. The inside was clean though. Reassembled and turned it over with the line to the carb detached and confirmed it was pumping. Reattached it and it still would not draw fuel through the line. Sprayed some gas in the carb and still nothing. I am thinking that for whatever reason there are too many choke points in the line so I am going to try removing the filter and hooking directly up to the pump again. But of course I cut my line to just the right length and without the filter it is too short, so I will have to go buy another line.

Made a nice rookie mistake that you guys might enjoy...left the lights on overnight so the battery died. Had to let it sit on the charger overnight just to confirm still not working!!
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top