Green Tractor Talk banner

^%$&* John Deere - problem RESOLVED

3761 Views 23 Replies 15 Participants Last post by  BOBL
Started to assemble my single point hydraulics connector today. I open the box and ALL of the small parts are thrown into the box loose. A quick inventory finds that I am missing 4ea. quick disconnects, 3ea. nuts for the bracket bolts, and the smaller bolts and nuts. I've sent an email to my dealer, and I'm sure I can use connectors from the hoses I remove, and buy nuts at the hardware store, but the point is an item that costs over $600 should be more carefully inventoried and packed. I'm used to premium parts and service from Deere, and this falls way short of my expectations.
1 - 3 of 3 Posts
That is not how mine arrived. Everything was neatly packed in sealed bags. Even the hoses. Nothing was without its own internal packaging. Perhaps yours is a returned package, or otherwise had been opened up by someone and the box re-sealed. Mine was ordered from GreenFarmParts, but It was drop shipped from a Deere parts warehouse.
And the kit with missing parts gets back into the cycle.......

A bit off topic, but this is why I never buy the first item off the shelf at the big box stores. The returned defective items that are restocked are typically put in the front. Last thing I bought from the front of a shelf was a Siemens circuit breaker, which was DOA. I suspect the buyer of a new one simply cleaned up and returned his old one for a refund.
I agree. I would simply return it and have them give you a replacement kit.
For anyone who has not seen this kit, I am posting a link to the TTWT demonstration and installation video.

  • Like
Reactions: Tractor Tim
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top