Green Tractor Talk banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Im trying to fix the in laws LA145. Its the 48" 22hp B&S. It turns over fine but wont fire. I have confirmed fuel comes out of pump, filter is new, plugs are new. I can hear the fuel shut off solenoid click every time the key is turned on and off, but haven't removed it yet. It will start and run if I spray starting fluid into intake. Im guessing the carb is gummed up. What you guys think?
 

·
Registered
Joined
·
967 Posts
In my previous life I owned an LA-145. It had over 350Hours on it when it went to the next owner. Decent tractor that never gave me a problem. "If" I were you, I would start with Inspecting and cleaning the complete fuel system which includes rebuilding the carburetor.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Today I blew air through the fuel line after the pump, then poured seafoam into the line. It then ran ok for about 10 minutes before quitting again. So I'm fairly confident its the carb, or the fuel pump is pumping intermittently.
 

·
Premium Member
Joined
·
7,670 Posts
As HouseMouse suggested, check the entire fuel system from tank to carb. I had a L-130 that exhibited all the same problems you're having. A new filter and fuel pump didn't help, and the carb was as clean as a whistle. I was getting a little bit of gas; but not enough. I blew air back through the line from the filter to the tank and had a gas geyser. I sold the blasted thing to a gear head buddy and he found out the fuel hose from the tank to the filter had rotted away enough to form a check valve. New hose and he's happy. Damn ethanol gas!
 
1 - 5 of 5 Posts
Top