Green Tractor Talk banner

1 - 20 of 105 Posts

·
Premium Member
'20 1025R, 120R, 54D
Joined
·
1,794 Posts
Discussion Starter · #1 ·
Was using the loader when I noticed a leak at the SPHC. I tried to take the loader off but it just started spraying from between the 2 mating pieces. I removed the connector and this was sitting inside one of the couplers. Looks to be a broken seal of some sort.

790270


790271


I checked JD PARTS for BXX10283 but can't seem to find anything but the entire upper coupling... no individual repair parts.


Can anyone point me in the right direction? The loader is not usable due to the excessive leak.
 

·
Premium Member
'20 1025R, 120R, 54D
Joined
·
1,794 Posts
Discussion Starter · #2 ·
I found some tech docs at Faster Couplings that talk about seal and/or coupler replacement but still can't locate any part numbers.

I also sent an email to Green Part Store thinking there should be some sort of warranty on this.
 

·
Registered
Joined
·
1,549 Posts
Sounds like you should’ve got a higher quality kubota tractor......... 🤣 jk.....

Seriously it sucks that it only lasted a week tho. 😐
 

·
Registered
Joined
·
1,258 Posts
That's kinda like what happened to me the first go around. I had spraying all over when tried to lock the lever after a couple weeks.Took it to my dealer & they said it was defective. Mine could've been a seal to but I or the dealer didn't find anything like that peice you have. I contacted Green Parts Store & told them the situation they asked me if I wanted a replacement kit or full refund. I went with the refund. They emailed me a packing slip & said they would pay for return shipping. So hopefully they will work with you also. They are decent people & I have never had any complaints on them. Good luck & hope all works out for you.

On another note I hope I'm not regretting getting this again. I've had it on for a week & no issues.🤞
 

·
Premium Member
'20 1025R, 120R, 54D
Joined
·
1,794 Posts
Discussion Starter · #5 ·
That's kinda like what happened to me the first go around. I had spraying all over when tried to lock the lever after a couple weeks.Took it to my dealer & they said it was defective. Mine could've been a seal to but I or the dealer didn't find anything like that peice you have. I contacted Green Parts Store & told them the situation they asked me if I wanted a replacement kit or full refund. I went with the refund. They emailed me a packing slip & said they would pay for return shipping. So hopefully they will work with you also. They are decent people & I have never had any complaints on them. Good luck & hope all works out for you.

On another note I hope I'm not regretting getting this again. I've had it on for a week & no issues.🤞
Hopefully GPS can help me. If they want to exchange it that's fine with me.
 

·
Registered
Joined
·
1,258 Posts
  • Like
Reactions: MarkEagleUSA

·
Premium Member
1025R, '30 Ford, '08 Range Rover Supercharged, '63 MGB, '92 300ZX twin turbo, '73 Courier 2.3 turbo
Joined
·
437 Posts
That's kinda like what happened to me the first go around. I had spraying all over when tried to lock the lever after a couple weeks.Took it to my dealer & they said it was defective. Mine could've been a seal to but I or the dealer didn't find anything like that peice you have. I contacted Green Parts Store & told them the situation they asked me if I wanted a replacement kit or full refund. I went with the refund. They emailed me a packing slip & said they would pay for return shipping. So hopefully they will work with you also. They are decent people & I have never had any complaints on them. Good luck & hope all works out for you.

On another note I hope I'm not regretting getting this again. I've had it on for a week & no issues.🤞
Yes, the GPS people are good. I'm sorry your single point system didn't work for you. Mine is still flawless after almost daily use over more than a year.
 

·
Premium Member
'20 1025R, 120R, 54D
Joined
·
1,794 Posts
Discussion Starter · #8 ·
Just heard back from GPS... need to send them some info and pics so they can initiate the warranty process.
 

·
Premium Member
1025R, '30 Ford, '08 Range Rover Supercharged, '63 MGB, '92 300ZX twin turbo, '73 Courier 2.3 turbo
Joined
·
437 Posts
Was using the loader when I noticed a leak at the SPHC. I tried to take the loader off but it just started spraying from between the 2 mating pieces. I removed the connector and this was sitting inside one of the couplers. Looks to be a broken seal of some sort.

View attachment 790270

View attachment 790271

I checked JD PARTS for BXX10283 but can't seem to find anything but the entire upper coupling... no individual repair parts.


Can anyone point me in the right direction? The loader is not usable due to the excessive leak.
I have a booklet from FASTER that shows all the parts and how to replace and source the seals and other components. PM me with your email address and I'll scan it for you. FASTER makes the JD single pt system.
 

·
Administrator
Joined
·
20,482 Posts
I have a booklet from FASTER that shows all the parts and how to replace and source the seals and other components. PM me with your email address and I'll scan it for you. FASTER makes the JD single pt system.
Can you make it a pdf and upload it here?
 

·
Premium Member
Joined
·
1,246 Posts
I am sure it not the case,,,but there is no chance that was there when you put the SP together and it did not fall out? I know I check the surfaces to make sure I have no debris in there. Was wondering if something in between would cause a leak. I went out to look at mine and it seems strange that the seal came out...
 

·
Premium Member
'20 1025R, 120R, 54D
Joined
·
1,794 Posts
Discussion Starter · #12 ·
Here's a few pics. Thank God for red dye!

Wiped clean before connection.
790458


Oil flowing down the coupler bracket.
790459


Hard to tell but there's a drop on the upper coupler, which is where I found the remnant of the seal.
790460
 

·
Premium Member
'20 1025R, 120R, 54D
Joined
·
1,794 Posts
Discussion Starter · #13 ·
I am sure it not the case,,,but there is no chance that was there when you put the SP together and it did not fall out? I know I check the surfaces to make sure I have no debris in there. Was wondering if something in between would cause a leak. I went out to look at mine and it seems strange that the seal came out...
It definitely was not there at install, or even Saturday when I put the loader back on after mowing. I always check the both sides are clean before connecting, especially the loader side since it has no protection.
 

·
Registered
Joined
·
1,549 Posts
Thats too many leaks for the one piece of junk to have caused. Are you sure the cam lock is getting tight enough?
 
  • Like
Reactions: Mackford13

·
Premium Member
'20 1025R, 120R, 54D
Joined
·
1,794 Posts
Discussion Starter · #15 ·
Thats too many leaks for the one piece of junk to have caused. Are you sure the cam lock is getting tight enough?
That's one leak. It's higher where the arrow points so the fluid runs down the face of the connector block to the other ports.
 

·
Premium Member
1025R, '30 Ford, '08 Range Rover Supercharged, '63 MGB, '92 300ZX twin turbo, '73 Courier 2.3 turbo
Joined
·
437 Posts
Can you make it a pdf and upload it here?
I'll try to do that later today - after my MGB valves and timing adjustments, followed by carburetor balancing. I'm better at that than computer work...
 

·
Registered
Joined
·
168 Posts
That's one leak. It's higher where the arrow points so the fluid runs down the face of the connector block to the other ports.
Hey Mark, It stinks that you're dealing with these issues with the SPHC. Are you planning on returning it for another SPHC or will you uninstall it permanently and get your money back?

I'm having the dealer install mine as part of my 1025R order and I hope there are no issues like you're experiencing.
 

·
Premium Member
'20 1025R, 120R, 54D
Joined
·
1,794 Posts
Discussion Starter · #18 ·
Hey Mark, It stinks that you're dealing with these issues with the SPHC. Are you planning on returning it for another SPHC or will you uninstall it permanently and get your money back?

I'm having the dealer install mine as part of my 1025R order and I hope there are no issues like you're experiencing.
I'm hoping GPS offers an exchange since repair parts don't seem to be available from Deere. I love the convenience of the SPHC so I do want to keep it.
 

·
Registered
Joined
·
1,258 Posts
Just heard back from GPS... need to send them some info and pics so they can initiate the warranty process.
Glad to hear you heard back from them.
 

·
Premium Member
1025R, '30 Ford, '08 Range Rover Supercharged, '63 MGB, '92 300ZX twin turbo, '73 Courier 2.3 turbo
Joined
·
437 Posts
I'm hoping GPS offers an exchange since repair parts don't seem to be available from Deere. I love the convenience of the SPHC so I do want to keep it.
My unit looks different. Mine is closer to square rather than a long rectangle like yours, but I'll bet the internal construction is the same. PDF tomorrow.
 
1 - 20 of 105 Posts
Top