Green Tractor Talk banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I purchased a used LT150. The Kohler 15hp runs great. The problem I have is the forward pedal functions as reverse and the reverse pedal functions as forward. I have looked at the pedal linkage and cannot identify what is causing the issue. Anyone who can provide advice on how to solve the problem is greatly appreciated!

Gary
 

·
Administrator
Joined
·
20,664 Posts
Welcome to GTT!

Here's the only thing I can post from JDParts.com that could help.



Maybe check to see if your engine-to-trans belt is routed correctly too. :good2:



Also, let me know if you want your username changed. We gets tons of traffic here to include spambots. They'll harvest your email in a heartbeat and sign you up for all kinds of junk. :thumbsdown:
 

·
Registered
Joined
·
1,973 Posts
It's a long shot but just in case it's possible that the PO tried to work on the transaxle there is a possibility that something inside was reversed making forward and reverse opposite.

The Tuff Torq K46 in lots of JD and other brand riding mowers is a favorite of DIY'ers to try and fix and it's common to reverse the location of a small part causing this issue. Not saying your LT150 has the same transaxle, but if it does it's a possibility and if it does not perhaps it still is possible if the trans was opened before you purchased it.
 

·
Registered
Joined
·
77 Posts
As I did research before rebuilding my K46 transaxle there was one caution that was repeated multiple times from various sources; If during the rebuild you place the wedge shaped block in upside down the transaxle will function in reverse operation when pedals are depressed...forward pedal = reverse tractor movement. Sounds like the previous owner made a common mistake. It's a fairly easy fix if you're mechanically inclined.
 
1 - 5 of 5 Posts
Top