Green Tractor Talk banner

1 - 6 of 6 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
I want to change out all the fluids on my MT and struggling with a few of the locations.

For the lift/lower hydraulics there's two potential locations but not sure. There looks like a fill point between the seat and the two controls here:

uploadfromtaptalk1372606075544.jpg

Additionally, there appear to be a drain, petcock and fill/check point on the back below the seat here:

uploadfromtaptalk1372606153168.jpg

I think these are for the same hydraulic reservoir. Anyone familiar with this?

Thanks!

Sent from my ASUS Transformer Pad TF300T using Tapatalk 2
 

·
Registered
Joined
·
2,044 Posts
I had a 40U, and as far as I know the TOMs are pretty darn similar.
In your top photo, that is the breather/fill location.
In your bottom photo, yes, the bottom plug is a drain plug, the petcock is where you check the fill level (it should be full enough to run out of the petcock), and I'm not sure what the top plug is for as I never used it or opened it.

I will say, if you just open the petcock and add fluid into the top breather/fill hole until it runs out the petcock, when the fluid heats up you will get some overflow from the breather. I used to just wipe off the overflow, and then check it again the following spring (unless I saw a noticeable leak).
 

·
Registered
Joined
·
27 Posts
Discussion Starter #3
Thanks Andy! I think it's bone dry right now. From what I have read, sounds like any universal hydraulic fluid will do the trick. Is that what you used?

Sent from my PG86100 using Tapatalk 2
 

·
Registered
Joined
·
2,044 Posts
Yup. I just go to Sam's Club or AutoZone and buy the 5 gallon bucket of whatever is cheapest. In the 10 years I ran the tractor that is all I used and I never had a problem with seals or leaks.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #5
Forgot to ask... Is there a hydraulic filter for this system? I assume not and haven't found one anywhere.

Sent from my PG86100 using Tapatalk 2
 

·
Registered
Joined
·
2,044 Posts
There wasn't one on my 40U, so I'd say there probably isn't one on an MT.
 
1 - 6 of 6 Posts
Top