Green Tractor Talk banner

1 - 9 of 9 Posts

·
Premium Member
Joined
·
1,224 Posts
Discussion Starter #1 (Edited)
I had to work today and got home was going to do some night time mowing and found out my pto won't turn on light on dash says its on but the mid shaft won't turn I tried moving the lever to the rear shaft and still won't turn on I need to know where to look first or should I call jd to pick it up might still be under warranty I did check the linkage from the shifter and it looks to be working properly I just don't know where to start looking for problem without alot of disassembly P_20190713_220604.jpg P_20190713_220301.jpg

Sent from my ASUS_A009 using Tapatalk
 

·
Registered
Joined
·
3,929 Posts
Had that problem with my x595, for some reason the gears didn't mesh. I moved it down to the rear pto turned it on and off then moved it back up to the mm pto and the lever went a bit farther and worked.
 

·
Registered
Joined
·
2,980 Posts
I would be looking at seat switch wires for pinching and pto wires to check if brush may have caught them.
 
  • Like
Reactions: bmichael

·
Super Moderator
Joined
·
5,287 Posts
Looking at the Service Manual, there appears to be very few possibilities based on your symptoms.

The first possibility is that your A1 control module (the "brains" of your tractor) has died. It is seeing that your used the selector and turned the PTO switch on (indicated by turning on the PTO indicator lamp) but not taking that data and activating the PTO solenoid.

The 2nd is that the PTO solenoid is either disconnected or dead. The PTO solenoid is located behind the right rear wheel just above the hydro sump filter screen. You might check to make sure the wiring to it is in place and did't get pulled off somehow.
 
  • Like
Reactions: bmichael

·
Premium Member
Joined
·
1,224 Posts
Discussion Starter #5
I looked at the pto solenoid and Appears to. Be connected I don't think it's a mechanical issue I think it's electrical I call the dealer tomorrow I think I still have warranty coverage since I only have 54 hrs on it

Sent from my ASUS_A009 using Tapatalk
 

·
Premium Member
Joined
·
1,224 Posts
Discussion Starter #6
I called the dealer today tractor is still under warranty they pick it up next week

Sent from my ASUS_A009 using Tapatalk
 
  • Like
Reactions: Kennyd and theduke

·
Registered
Joined
·
171 Posts
JD will still likely try to charge you for a service call, particularly if they picked it up. I had LOTS of these on the 1025R. Got my sales person to eat them, as all were on 2 year warranty.

Did you try wiggling the PTO switch? I have to wiggle it on the 2025R. Can get it to stay engaged by wiggling. PITA to remove the old switch.

Hope they fix it with no charge to you.

Ralph
 

·
Administrator
Joined
·
20,970 Posts
I moved this thread to the MCUT forum for more views and responses.

Please let me know if this isn’t the tractor you have in your signature so the thread can be put in the correct forum. :good2:
 

·
Registered
Joined
·
168 Posts
Not sure.of model, but my 2025R did the same thing. The RIO switch underneath was not contacting the stop-it thought the tractor was in reverse, so pto wouldn't engage.

It had been bent by a branch I ran over while in the woods. It got tangled up in the reverse linkage.
 
  • Like
Reactions: BigJim55
1 - 9 of 9 Posts
Top