Green Tractor Talk banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Pushes and steers fine at 3/4 throttle but not at full throttle. Have all new filters on it. Any ideas? All help appreciated.
 

·
Administrator
Joined
·
17,088 Posts
Welcome to DT Cowman:morning2:

We need more info to help...but is sounds like the IP (injection pump) may need a rebuild, that's why Brian is asking about the smoke.
 

·
Premium Member
Joined
·
6,593 Posts
Welcome to DT Cowman.:thumbup1gif:
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
At full RPM it doesn't push strong and kind of stalls a little until you back off to about 3/4 throttle then it gets a surge. Motor power seems good but does seems to surge a few times under a real hard push. It almost seems like the pumps are starving for oil. The left side pulls a little stronger than the right. Unk hours. Haven't had it very long. Unk history. Appreciate your time and the welcomes.
 

·
Administrator
Joined
·
17,088 Posts
It sounds like you have two problems, one the engine and one the hydraulic system. I would tackle the engine first-maybe get the injectors tested at a local shop, and possible the timing checked also. Once the engine is running strong you can move to the hydraulic system.
 

·
Premium Member
Joined
·
3,565 Posts
How long has it sat before you got it and started using it? I ask because these things usually sit outside and people leave them with a half tank of fuel. I would treat the helk out of the fuel and if you can see the filters through a sight glass, check that they are not plugged up again.

I agree with Kenny, the injectors and the injection pump might be bad on the engine side.
 
1 - 7 of 7 Posts
Top