Green Tractor Talk banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I own a 2006 John Deere X320 Lawn Tractor with almost 900 hours on it. After I refurbished the deck the other day, I got to looking at the transmission drive belt and decided to replace it, as it was badly cracked and worn. I uploaded a video to YouTube and posted the link below. Does the drive belt seem to be wobbling a little too much? I followed the routing instructions exactly, and it's around all of the pulleys and belt guards. Unfortunately, I didn't watch the old belt with the engine running, so I have nothing to compare it to .I just wanted to get it off and get the new one on. It is an aftermarket belt I purchased on Amazon, manufactured by Stens for the X320.
Here's the link.https://www.youtube.com/watch?v=WJYwIZyZt9Q


Also, since I had the mower torn apart, I noticed the bottom of the engine where the crankshaft turns the pulleys, was also wobbling a little bit. Here's another video for showing that.
https://www.youtube.com/watch?v=xoz0gklUClA

Thank you for watching, any insight would be appreciated!
 

·
Registered
Joined
·
3,831 Posts
That's normal,the belt running through the spring tension makes it do that. Pto the same.
 

·
Registered
Joined
·
359 Posts
I own a 2006 John Deere X320 Lawn Tractor with almost 900 hours on it. After I refurbished the deck the other day, I got to looking at the transmission drive belt and decided to replace it, as it was badly cracked and worn. I uploaded a video to YouTube and posted the link below. Does the drive belt seem to be wobbling a little too much? I followed the routing instructions exactly, and it's around all of the pulleys and belt guards. Unfortunately, I didn't watch the old belt with the engine running, so I have nothing to compare it to .I just wanted to get it off and get the new one on. It is an aftermarket belt I purchased on Amazon, manufactured by Stens for the X320.
Here's the link.https://www.youtube.com/watch?v=WJYwIZyZt9Q


Also, since I had the mower torn apart, I noticed the bottom of the engine where the crankshaft turns the pulleys, was also wobbling a little bit. Here's another video for showing that.
https://www.youtube.com/watch?v=xoz0gklUClA

Thank you for watching, any insight would be appreciated!
The video of the engine pulley leaves me to believe that you may have a broken or loose motor mount. Check them all and replace any that are suspect. It's not normal for the engine to shake as much as that.
 

·
Premium Member
Joined
·
10,946 Posts
The video of the engine pulley leaves me to believe that you may have a broken or loose motor mount. Check them all and replace any that are suspect. It's not normal for the engine to shake as much as that.
To me it looks like the PTO clutch is jiggling back and forth which might be normal since the only thing holding it from turning is a little fork against a metal tab.
 
1 - 5 of 5 Posts
Top