Green Tractor Talk banner

1 - 4 of 4 Posts

·
Super Moderator
Joined
·
5,099 Posts
Discussion Starter #1
I know some other folks have been having issues with shipping but not here.

I ordered a diverter kit for my tractor on Tuesday evening at about 6pm. It arrived on my doorstep this morning (Friday) before 9am. I set it aside while I drank my morning coffee and did some running around.

I found myself with a few spare hours mid-day so at about noon I started installing and was done by 2pm.

The loader curl function seems to work fine. I haven't had a need to put the plow on it yet to see how that side works but the lines do pressurize. I'll have to put the plow on for testing over the weekend.

By the time I was done installing and came in to check on email, I had an email from Peter @ 9:30am saying that it had shipped. :laugh: I guess shipping is fast if you're only 10 miles away.
 

·
Premium Member
Joined
·
2,735 Posts
Glad things went well for you. I ordered mine just after Curtis bought them out. Took about 4 weeks to get mine but once I had it everything went well.
 

·
Super Moderator
Joined
·
5,099 Posts
Discussion Starter #3
Not sure if anyone else has run into this or not but I think something in the packaging of my kit got labeled wrong.

I connected all of the hoses exactly as the directions said to and all of the hose ends had a sticker on then saying where to connect them. I checked, double checked and triple checked to make sure I had every single one of them connected as labeled.

When I got done and tested, the curl function was reversed from normal. Usually I pull the joystick in (to the left) to curl the bucket and out (to the right) to dump. After installing the diverter, pulling in dumped the bucket and pushing out curled it.

It was easy enough to fix. I just swapped the hydraulic lines at the SCV and changed the cap colors on them.
 

·
Registered
Joined
·
1,102 Posts
Not sure if anyone else has run into this or not but I think something in the packaging of my kit got labeled wrong.

I connected all of the hoses exactly as the directions said to and all of the hose ends had a sticker on then saying where to connect them. I checked, double checked and triple checked to make sure I had every single one of them connected as labeled.

When I got done and tested, the curl function was reversed from normal. Usually I pull the joystick in (to the left) to curl the bucket and out (to the right) to dump. After installing the diverter, pulling in dumped the bucket and pushing out curled it.

It was easy enough to fix. I just swapped the hydraulic lines at the SCV and changed the cap colors on them.
I changed the diverter hose to clamp/tilt the snow plow hoses. I didn't like pulling the leaver in to make the grapple close. Caused me to lose my load at times.
 
1 - 4 of 4 Posts
Top