Green Tractor Talk banner

1 - 11 of 11 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi everyone I am from the UK and recently traded my 2003 6300 in for an 05 6420s.

I bought the tractor with a starting issue that the seller sorted out. The glow plug light was flashing with the warning light and the tractor really struggled to start. He fixed the issue and said it was the crank sensor, he replaced with a new one and gave the tractor a service.

Today has been my first day I have used it properly and started hauling.
The same warning lights have come up again, the tractor starts but not immediately. I don't think the battery is much good anymore.
Does anyone have any ideas to what this could be?

Cheers
Alex
 

·
GTT's Pilot in Command (PIC)
Joined
·
8,558 Posts
Unfortunately, I cannot help with the issue that you are having, but still wanted to say.....

:gtfam:
 

·
Registered
Joined
·
4,485 Posts
:wgtt:

Welcome from New York. I hope you get the problems ironed out in your "new to you" tractor.
 

·
Super Moderator
Joined
·
5,584 Posts
:gtfam:
 

·
Premium Member
Joined
·
14,899 Posts
Welcome from West Virginia,, sorry I can't help .

:wgtt:
 

·
Registered
Joined
·
2 Posts
Discussion Starter #10
I will check it out and let you know.
I noticed after driving it all day yesterday as well that the fault come up when I change from E-2,3 or 4 to F.
The dash also briefly flashed dash voltage problem when I started it.

Thank you for all your help
Alex
 

·
Registered
Joined
·
2,175 Posts
:wgtt:
From CT
 
1 - 11 of 11 Posts
Top