Green Tractor Talk banner

1 - 6 of 6 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter #1 (Edited)
[/B
Hello eveyone. I recently picked up a 1995 445 with 1100 hrs on the clock. Seems to run well. Has had the cam gear upgrade. I did a full 200hr type service. What I don't knwo is why at a full cold start with 1/2 throttle or so, she will fire right up and then stumble and cough for 4-5 seconds like it's flooding. It then cleans up and runs very well for the rest of the day. Is this a function of a faulty sensor or just a trait of these fuel injected tractors? Any advice would be appreciated. It only occurs at cold start. Thanks, George
 

·
Registered
Joined
·
41 Posts
[/B
Hello eveyone. I recently picked up a 1995 445 with 1100 hrs on the clock. Seems to run well. Has had the cam gear upgrade. I did a full 200hr type service. What I don't knwo is why at a full cold start with 1/2 throttle or so, she will fire right up and then stumble and cough for 4-5 seconds like it's flooding. It then cleans up and runs very well for the rest of the day. Is this a function of a faulty sensor or just a trait of these fuel injected tractors? Any advice would be appreciated. It only occurs at cold start. Thanks, George


I have a 1996 445 with 1700 hours and it does the same thing. When cold it will cough and stumble for a few seconds. I have tried some fuel cleaner systems like Lucas and it seemed to help a little but never took it away altogether. I am thinking it is fuel delivery like a dirty injector but can't say for sure. I haven't had the time to look into yet and since my purchase of the 1025R it only gets used about a 1/2 hour a week now. If I do fine anything I will pass it along.
 

·
Registered
Joined
·
63 Posts
Discussion Starter #3
Thanks. I was thinking worn injector or sluggish MAP sensor. Nice to know I'm not alone. George
 

·
Registered
Joined
·
63 Posts
Discussion Starter #4
Here's an update. Tonight I tried to start the 445. It tried to start, caught fired and promptly flooded itself out. Had to take out the plugs and dry them. Then it started and ran good the rest of the night. I'm thinking more and more that it needs a MAP sensor. Doe s anybody have any other ideas? Thanks, George
 

·
Registered
Joined
·
63 Posts
Discussion Starter #5
Still haven't resolved my stumbling issues. Tractor has gotten worse. If it sits for a day or two, it will start, and then about 5 seconds later it will start to cough and choke. Usually it clears out and runs well for the rest of the day, with multiple restarts not a problem. If I let it sit for a week or more it seems to just flood itself out at startup. Failing to start at all. After I pull the plugs, dry them out and clear the excess fuel from the cylinders, it will fire right up and run fine for the rest of the day. Seems like it is loading up with fuel while sitting or during the 2 seconds or so that the fuel pump runs before cranking it over.

What are the symptoms of a leaking fuel injector? or if the o rings around the injector go bad?

Getting frustrated. Thanks, George
 

·
Registered
Joined
·
41 Posts
Still haven't resolved my stumbling issues. Tractor has gotten worse. If it sits for a day or two, it will start, and then about 5 seconds later it will start to cough and choke. Usually it clears out and runs well for the rest of the day, with multiple restarts not a problem. If I let it sit for a week or more it seems to just flood itself out at startup. Failing to start at all. After I pull the plugs, dry them out and clear the excess fuel from the cylinders, it will fire right up and run fine for the rest of the day. Seems like it is loading up with fuel while sitting or during the 2 seconds or so that the fuel pump runs before cranking it over.

What are the symptoms of a leaking fuel injector? or if the o rings around the injector go bad?

Getting frustrated. Thanks, George
My 445 is throttle body injected. If yours is the same you should be able to look down the throttle body when you turn the key to run and see if fuel is dripping out of the injector before you start the engine. Otherwise the only way to tell if there is a leak would be to hook a pressure gage up in the system and monitor the pressure to see if it falls off. Does the fuel injection light on the dash blink any codes while this is going on? My 445 has a similar problem and the light blinks a Long Long Short Short code. Which the manual says it's a possible bad MAP sensor. I haven't had time to test it yet. When I do I will pass along the findings.
 
1 - 6 of 6 Posts
Top